summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-01 09:02:19 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-01 09:02:19 +0000
commitab7d6d190ff323b1d46ea570f62a4df275790a78 (patch)
treeb46ddde05f059f7b865401ea8f1e0ea843bb825e /dev-python/alembic
parentVersion bump. (diff)
downloadgentoo-2-ab7d6d190ff323b1d46ea570f62a4df275790a78.tar.gz
gentoo-2-ab7d6d190ff323b1d46ea570f62a4df275790a78.tar.bz2
gentoo-2-ab7d6d190ff323b1d46ea570f62a4df275790a78.zip
bump; drop py2.6 3.2 add py3.4, upgrade test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/ChangeLog7
-rw-r--r--dev-python/alembic/alembic-0.6.4.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/alembic/ChangeLog b/dev-python/alembic/ChangeLog
index 7f9e377231fd..bc4ad111aebc 100644
--- a/dev-python/alembic/ChangeLog
+++ b/dev-python/alembic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/alembic
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/alembic/ChangeLog,v 1.11 2014/03/22 04:24:16 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/alembic/ChangeLog,v 1.12 2014/05/01 09:02:19 idella4 Exp $
+
+*alembic-0.6.4 (01 May 2014)
+
+ 01 May 2014; Ian Delaney <idella4@gentoo.org> +alembic-0.6.4.ebuild:
+ bump; drop py2.6 3.2 add py3.4, upgrade test phase
22 Mar 2014; Ian Delaney <idella4@gentoo.org> alembic-0.6.0.ebuild,
alembic-0.6.3.ebuild:
diff --git a/dev-python/alembic/alembic-0.6.4.ebuild b/dev-python/alembic/alembic-0.6.4.ebuild
new file mode 100644
index 000000000000..9be0b085a1e9
--- /dev/null
+++ b/dev-python/alembic/alembic-0.6.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/alembic/alembic-0.6.4.ebuild,v 1.1 2014/05/01 09:02:19 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+# requires.txt cites 'SQLAlchemy>=0.7.3' which is really both old and silly
+# because it shatters the testsuite. If 'someone' cares to adhere to correct form
+# and edit to -0.7.3, feel free, and then pick up the pieces.
+RDEPEND=">=dev-python/sqlalchemy-0.8.4[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# For test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # suite passes all if run from source. The residual fail & error are quite erroneous
+ sed -e 's:class SourcelessVersioningTest(VersioningTest):#&:' \
+ -e 's:sourceless = True:#&:' \
+ -e 's:test_needs_flag:_&:' \
+ -i tests/test_versioning.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests tests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}