summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-06 12:42:18 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-06 12:42:18 +0000
commit60870a39426427e2aa92c03b9a6c6f48dc37c3b0 (patch)
tree3ac31af1092ddc39406fdd6a95599da87fc355d1 /dev-python/apiextractor
parentAdd missing patch, thanks to marienz (diff)
downloadgentoo-2-60870a39426427e2aa92c03b9a6c6f48dc37c3b0.tar.gz
gentoo-2-60870a39426427e2aa92c03b9a6c6f48dc37c3b0.tar.bz2
gentoo-2-60870a39426427e2aa92c03b9a6c6f48dc37c3b0.zip
Bump pyside to latest release. Punt older that i didn't manage to make behave.
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/apiextractor')
-rw-r--r--dev-python/apiextractor/ChangeLog9
-rw-r--r--dev-python/apiextractor/apiextractor-0.10.3.ebuild37
-rw-r--r--dev-python/apiextractor/apiextractor-0.10.6.ebuild (renamed from dev-python/apiextractor/apiextractor-0.10.0.ebuild)24
-rw-r--r--dev-python/apiextractor/apiextractor-0.8.1.ebuild37
4 files changed, 19 insertions, 88 deletions
diff --git a/dev-python/apiextractor/ChangeLog b/dev-python/apiextractor/ChangeLog
index 1f154c20077f..bf55bd148636 100644
--- a/dev-python/apiextractor/ChangeLog
+++ b/dev-python/apiextractor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/apiextractor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/ChangeLog,v 1.11 2011/05/27 18:16:29 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/ChangeLog,v 1.12 2011/09/06 12:42:17 scarabeus Exp $
+
+*apiextractor-0.10.6 (06 Sep 2011)
+
+ 06 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ -apiextractor-0.8.1.ebuild, -apiextractor-0.10.0.ebuild,
+ -apiextractor-0.10.3.ebuild, +apiextractor-0.10.6.ebuild:
+ Version bump to latest release. Cleanup ebuild. Remove older.
*apiextractor-0.10.3 (27 May 2011)
diff --git a/dev-python/apiextractor/apiextractor-0.10.3.ebuild b/dev-python/apiextractor/apiextractor-0.10.3.ebuild
deleted file mode 100644
index 6170bb4a2a68..000000000000
--- a/dev-python/apiextractor/apiextractor-0.10.3.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.10.3.ebuild,v 1.1 2011/05/27 18:16:30 chiiph Exp $
-
-EAPI="2"
-
-inherit cmake-utils virtualx
-
-DESCRIPTION="Library used to create an internal representation of an API in order to create Python bindings"
-HOMEPAGE="http://www.pyside.org/"
-SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug test"
-
-RDEPEND=">=dev-libs/boost-1.41.0[python]
- dev-libs/libxml2
- dev-libs/libxslt
- >=x11-libs/qt-core-4.5.0
- >=x11-libs/qt-xmlpatterns-4.5.0"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- test? ( >=x11-libs/qt-test-4.5.0 )"
-TEST_VERBOSE="1"
-
-src_configure() {
- mycmakeargs="$(cmake-utils_use_build test TESTS)"
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc AUTHORS ChangeLog || die "dodoc failed"
-}
diff --git a/dev-python/apiextractor/apiextractor-0.10.0.ebuild b/dev-python/apiextractor/apiextractor-0.10.6.ebuild
index 0556c6d0c2be..d9548be07f1d 100644
--- a/dev-python/apiextractor/apiextractor-0.10.0.ebuild
+++ b/dev-python/apiextractor/apiextractor-0.10.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.10.0.ebuild,v 1.1 2011/03/20 19:08:13 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.10.6.ebuild,v 1.1 2011/09/06 12:42:17 scarabeus Exp $
-EAPI="2"
+EAPI=4
-inherit cmake-utils virtualx
+inherit cmake-utils
DESCRIPTION="Library used to create an internal representation of an API in order to create Python bindings"
HOMEPAGE="http://www.pyside.org/"
@@ -18,20 +18,18 @@ IUSE="debug test"
RDEPEND=">=dev-libs/boost-1.41.0[python]
dev-libs/libxml2
dev-libs/libxslt
- >=x11-libs/qt-core-4.5.0
- >=x11-libs/qt-xmlpatterns-4.5.0"
+ >=x11-libs/qt-core-4.7.0
+ >=x11-libs/qt-xmlpatterns-4.7.0"
DEPEND="${RDEPEND}
dev-util/pkgconfig
- test? ( >=x11-libs/qt-test-4.5.0 )"
-TEST_VERBOSE="1"
+ test? ( >=x11-libs/qt-test-4.7.0 )"
+
+DOCS=( AUTHORS ChangeLog )
src_configure() {
- mycmakeargs="$(cmake-utils_use_build test TESTS)"
+ local mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ )
cmake-utils_src_configure
}
-
-src_install() {
- cmake-utils_src_install
- dodoc AUTHORS ChangeLog || die "dodoc failed"
-}
diff --git a/dev-python/apiextractor/apiextractor-0.8.1.ebuild b/dev-python/apiextractor/apiextractor-0.8.1.ebuild
deleted file mode 100644
index fdb69b9b017a..000000000000
--- a/dev-python/apiextractor/apiextractor-0.8.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.8.1.ebuild,v 1.1 2010/11/25 01:16:25 chiiph Exp $
-
-EAPI="2"
-
-inherit cmake-utils virtualx
-
-DESCRIPTION="Library used to create an internal representation of an API in order to create Python bindings"
-HOMEPAGE="http://www.pyside.org/"
-SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug test"
-
-RDEPEND=">=dev-libs/boost-1.41.0[python]
- dev-libs/libxml2
- dev-libs/libxslt
- >=x11-libs/qt-core-4.5.0
- >=x11-libs/qt-xmlpatterns-4.5.0"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- test? ( >=x11-libs/qt-test-4.5.0 )"
-TEST_VERBOSE="1"
-
-src_configure() {
- mycmakeargs="$(cmake-utils_use_build test TESTS)"
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc AUTHORS ChangeLog || die "dodoc failed"
-}