summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-02-27 18:26:15 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-02-27 18:26:15 +0000
commitb0df56e6559b5fff48dd6d7e197ddc8ed4f10666 (patch)
treea78182b15d2bd757ecb4271870646c1d833755e6 /dev-python/autopep8
parentInstall samples in proper FHS directory. Python routines now installed withou... (diff)
downloadgentoo-2-b0df56e6559b5fff48dd6d7e197ddc8ed4f10666.tar.gz
gentoo-2-b0df56e6559b5fff48dd6d7e197ddc8ed4f10666.tar.bz2
gentoo-2-b0df56e6559b5fff48dd6d7e197ddc8ed4f10666.zip
Add live ebuild
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/ChangeLog7
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/autopep8/ChangeLog b/dev-python/autopep8/ChangeLog
index 25fde021fd53..8cb69b65dc13 100644
--- a/dev-python/autopep8/ChangeLog
+++ b/dev-python/autopep8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/autopep8
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.2 2012/02/15 10:11:40 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.3 2012/02/27 18:26:15 xarthisius Exp $
+
+*autopep8-9999 (27 Feb 2012)
+
+ 27 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> +autopep8-9999.ebuild:
+ Add live ebuild
15 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> autopep8-0.5.ebuild:
Add src_test and missing dependency on dev-python/pep8. Fixes bug 403663 by
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
new file mode 100644
index 000000000000..8bf60a003249
--- /dev/null
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-9999.ebuild,v 1.1 2012/02/27 18:26:15 xarthisius Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SCM=git-2
+ EGIT_REPO_URI="git://github.com/hhatto/${PN}.git"
+fi
+
+inherit distutils ${SCM}
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/pep8"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+PYTHON_MODNAME="${PN}.py"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_${PN}.py
+ }
+ python_execute_function testing
+}