summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-10 01:23:11 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-10 01:23:11 +0000
commit5be9592580b58caf8512d96e660776b535dfcf97 (patch)
treef3e756ad60d53b12f1c180497e62bf2932803b80 /dev-python/beautifulsoup
parentUpdate dependencies with PYTHON_USEDEP. (diff)
downloadgentoo-2-5be9592580b58caf8512d96e660776b535dfcf97.tar.gz
gentoo-2-5be9592580b58caf8512d96e660776b535dfcf97.tar.bz2
gentoo-2-5be9592580b58caf8512d96e660776b535dfcf97.zip
Convert to distutils-r1.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/ChangeLog7
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.2.1-r1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index 921977feb2d5..e225cc40659a 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.85 2013/02/02 21:59:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.86 2013/02/10 01:23:11 floppym Exp $
+
+*beautifulsoup-3.2.1-r1 (10 Feb 2013)
+
+ 10 Feb 2013; Mike Gilbert <floppym@gentoo.org> +beautifulsoup-3.2.1-r1.ebuild:
+ Convert to distutils-r1.
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> beautifulsoup-4.1.3-r1.ebuild:
Stable for x86, wrt bug #454314
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.2.1-r1.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..b69286f71d4d
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.2.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.2.1-r1.ebuild,v 1.1 2013/02/10 01:23:11 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{5,6,7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_PN="BeautifulSoup"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/ http://pypi.python.org/pypi/BeautifulSoup"
+SRC_URI="http://www.crummy.com/software/${MY_PN}/download/3.x/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="python-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!dev-python/beautifulsoup:0"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${PYTHON}" BeautifulSoupTests.py || die "Testing failed with ${EPYTHON}"
+}