summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-24 15:07:14 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-24 15:07:14 +0000
commitf4b8e9bc951bd1c3f9fb0fefd2ba9822e037ce88 (patch)
treee0d5fe8f9dbfd29e6caaeedf2b02e32324f4035c /dev-python/billiard
parentalpha stable wrt bug #496172 (diff)
downloadgentoo-2-f4b8e9bc951bd1c3f9fb0fefd2ba9822e037ce88.tar.gz
gentoo-2-f4b8e9bc951bd1c3f9fb0fefd2ba9822e037ce88.tar.bz2
gentoo-2-f4b8e9bc951bd1c3f9fb0fefd2ba9822e037ce88.zip
bump; add IUSE test, test deps, unrestrict test phase
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/billiard')
-rw-r--r--dev-python/billiard/ChangeLog10
-rw-r--r--dev-python/billiard/billiard-2.7.3.32.ebuild4
-rw-r--r--dev-python/billiard/billiard-3.3.0.14.ebuild38
3 files changed, 48 insertions, 4 deletions
diff --git a/dev-python/billiard/ChangeLog b/dev-python/billiard/ChangeLog
index 55131efad7cc..93539d5b23c8 100644
--- a/dev-python/billiard/ChangeLog
+++ b/dev-python/billiard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/billiard
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/billiard/ChangeLog,v 1.18 2013/09/05 18:46:36 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/billiard/ChangeLog,v 1.19 2014/01/24 15:07:14 idella4 Exp $
+
+*billiard-3.3.0.14 (24 Jan 2014)
+
+ 24 Jan 2014; Ian Delaney <idella4@gentoo.org> +billiard-3.3.0.14.ebuild,
+ billiard-2.7.3.32.ebuild:
+ bump; add IUSE test, test deps, unrestrict test phase
05 Sep 2013; Michał Górny <mgorny@gentoo.org> billiard-2.7.3.20-r1.ebuild,
billiard-2.7.3.21.ebuild, billiard-2.7.3.22.ebuild, billiard-2.7.3.23.ebuild,
diff --git a/dev-python/billiard/billiard-2.7.3.32.ebuild b/dev-python/billiard/billiard-2.7.3.32.ebuild
index 431990714a34..9f8538b05afb 100644
--- a/dev-python/billiard/billiard-2.7.3.32.ebuild
+++ b/dev-python/billiard/billiard-2.7.3.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/billiard/billiard-2.7.3.32.ebuild,v 1.2 2013/09/05 18:46:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/billiard/billiard-2.7.3.32.ebuild,v 1.3 2014/01/24 15:07:14 idella4 Exp $
EAPI=5
diff --git a/dev-python/billiard/billiard-3.3.0.14.ebuild b/dev-python/billiard/billiard-3.3.0.14.ebuild
new file mode 100644
index 000000000000..4bfaa0ae5b4d
--- /dev/null
+++ b/dev-python/billiard/billiard-3.3.0.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/billiard/billiard-3.3.0.14.ebuild,v 1.1 2014/01/24 15:07:14 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python multiprocessing fork"
+HOMEPAGE="http://pypi.python.org/pypi/billiard https://github.com/celery/billiard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/unittest2-0.4.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests billiard.tests || die "Tests fail with ${EPYTHON}"
+}