summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-07-27 06:25:36 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-07-27 06:25:36 +0000
commit6ea9f8c83d4e70056837e3211b2c01ee1e15a2e6 (patch)
treec7c4d41c723006925ed7210ea2b7314bcbbf93ce /dev-python/bonobo-python
parentfew KEYWORDS?SLOT?LICENSE fixes (diff)
downloadgentoo-2-6ea9f8c83d4e70056837e3211b2c01ee1e15a2e6.tar.gz
gentoo-2-6ea9f8c83d4e70056837e3211b2c01ee1e15a2e6.tar.bz2
gentoo-2-6ea9f8c83d4e70056837e3211b2c01ee1e15a2e6.zip
few more clean-ups
Diffstat (limited to 'dev-python/bonobo-python')
-rw-r--r--dev-python/bonobo-python/ChangeLog7
-rw-r--r--dev-python/bonobo-python/bonobo-python-0.2.0-r1.ebuild23
2 files changed, 20 insertions, 10 deletions
diff --git a/dev-python/bonobo-python/ChangeLog b/dev-python/bonobo-python/ChangeLog
index 53e46e7b29fd..078f20eb9649 100644
--- a/dev-python/bonobo-python/ChangeLog
+++ b/dev-python/bonobo-python/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for dev-python/bonobo-python
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bonobo-python/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bonobo-python/ChangeLog,v 1.2 2002/07/27 06:25:36 george Exp $
*bonobo-python-0.2.0-r1 (1 Feb 2002)
+ 26 Jul 2002; George Shapovalov <george@gentoo.org> bonobo-python-0.2.0-r1.ebuild :
+
+ added KEYWORDS,SLOT,LICENSE
+ general clean-up (whitespace, header, try->||die)
+
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
Added initial ChangeLog which should be updated whenever the package is
diff --git a/dev-python/bonobo-python/bonobo-python-0.2.0-r1.ebuild b/dev-python/bonobo-python/bonobo-python-0.2.0-r1.ebuild
index 78605b4ae934..619f0fd03081 100644
--- a/dev-python/bonobo-python/bonobo-python-0.2.0-r1.ebuild
+++ b/dev-python/bonobo-python/bonobo-python-0.2.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bonobo-python/bonobo-python-0.2.0-r1.ebuild,v 1.4 2002/07/11 06:30:24 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bonobo-python/bonobo-python-0.2.0-r1.ebuild,v 1.5 2002/07/27 06:25:36 george Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Bonobo bindings for Python"
@@ -12,18 +12,23 @@ DEPEND="=x11-libs/gtk+-1.2*
>=dev-python/gnome-python-1.4.1-r2
>=dev-python/orbit-python-0.3.0-r1
virtual/python"
+RDEPEND="${RDEPEND}"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="GPL-2"
src_compile() {
- PYTHON="/usr/bin/python" try ./configure --host=${CHOST} --prefix=/usr \
- --with-libIDL-prefix=/usr --with-orbit-prefix=/usr \
- --with-oaf-prefix=/usr
- try make
+ PYTHON="/usr/bin/python" ./configure --host=${CHOST} --prefix=/usr \
+ --with-libIDL-prefix=/usr --with-orbit-prefix=/usr \
+ --with-oaf-prefix=/usr || die
+ make || die
}
src_install() {
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING ChangeLog NEWS
- dodoc README TODO
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS
+ dodoc README TODO
}