summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-12-09 20:08:20 +0000
committerMarinus Schraal <foser@gentoo.org>2002-12-09 20:08:20 +0000
commitd00b4d1373c6d0d69b07f7db0c7dfcb8ca96c8fa (patch)
tree97e31bad284d6b257c568d061018d30f5364645c /dev-python/bonobo-python
parentVersion bump. (diff)
downloadgentoo-2-d00b4d1373c6d0d69b07f7db0c7dfcb8ca96c8fa.tar.gz
gentoo-2-d00b4d1373c6d0d69b07f7db0c7dfcb8ca96c8fa.tar.bz2
gentoo-2-d00b4d1373c6d0d69b07f7db0c7dfcb8ca96c8fa.zip
fix in progress
Diffstat (limited to 'dev-python/bonobo-python')
-rw-r--r--dev-python/bonobo-python/bonobo-python-0.2.0-r2.ebuild45
-rw-r--r--dev-python/bonobo-python/files/digest-bonobo-python-0.2.0-r21
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/bonobo-python/bonobo-python-0.2.0-r2.ebuild b/dev-python/bonobo-python/bonobo-python-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..cdd568e3fe9d
--- /dev/null
+++ b/dev-python/bonobo-python/bonobo-python-0.2.0-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bonobo-python/bonobo-python-0.2.0-r2.ebuild,v 1.1 2002/12/09 20:08:20 foser Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Bonobo bindings for Python"
+SRC_URI="http://bonobo-python.lajnux.nu/download/${P}.tar.gz"
+HOMEPAGE="http://bonobo-python.lajnux.nu/"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=gnome-base/bonobo-1.0.9
+ <dev-python/gnome-python-1.99
+ =dev-python/orbit-python-0.3*
+ virtual/python"
+RDEPEND="${RDEPEND}"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+
+ # fix configure time sandbox problem
+ cd ${S}
+ mv configure configure.bad
+ sed -e "s:import gnome.config ; gnome.config.sync::" configure.bad > configure
+ chmod +x configure
+}
+
+src_compile() {
+ PYTHON=/usr/bin/python ./configure --host=${CHOST} --prefix=/usr \
+ --with-libIDL-prefix=/usr --with-orbit-prefix=/usr \
+ --with-oaf-prefix=/usr || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
+
+
+
diff --git a/dev-python/bonobo-python/files/digest-bonobo-python-0.2.0-r2 b/dev-python/bonobo-python/files/digest-bonobo-python-0.2.0-r2
new file mode 100644
index 000000000000..930fe4002637
--- /dev/null
+++ b/dev-python/bonobo-python/files/digest-bonobo-python-0.2.0-r2
@@ -0,0 +1 @@
+MD5 85a2d3fc437bc1235a5a5c72b8ab6f70 bonobo-python-0.2.0.tar.gz 275238