summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-02-05 01:34:00 +0000
committerTim Harder <radhermit@gentoo.org>2013-02-05 01:34:00 +0000
commit492731397277608360fe679e1ef00f2d313d5c10 (patch)
treef161ac8927721c27b751e130a33a1d1b7732a006 /dev-python/boto
parentRemove old. (diff)
downloadgentoo-2-492731397277608360fe679e1ef00f2d313d5c10.tar.gz
gentoo-2-492731397277608360fe679e1ef00f2d313d5c10.tar.bz2
gentoo-2-492731397277608360fe679e1ef00f2d313d5c10.zip
Version bump.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.8.0.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 5de1ef12a998..73d24225f36d 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.53 2013/01/25 04:50:57 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.54 2013/02/05 01:34:00 radhermit Exp $
+
+*boto-2.8.0 (05 Feb 2013)
+
+ 05 Feb 2013; Tim Harder <radhermit@gentoo.org> +boto-2.8.0.ebuild:
+ Version bump.
*boto-2.7.0 (25 Jan 2013)
diff --git a/dev-python/boto/boto-2.8.0.ebuild b/dev-python/boto/boto-2.8.0.ebuild
new file mode 100644
index 000000000000..f74b609d4b93
--- /dev/null
+++ b/dev-python/boto/boto-2.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.8.0.ebuild,v 1.1 2013/02/05 01:34:00 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/m2crypto )"
+RDEPEND="dev-python/m2crypto"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}