summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-02 07:56:14 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-02 07:56:14 +0000
commitce25c9fd2888eb188634051ba641ca3f57c2064c (patch)
tree46b0e24666ccc0eabefaee1c5ffc3673aa2a20be /dev-python/boto
parentInitial import. Stop using visio-like tools! Use this! (diff)
downloadgentoo-2-ce25c9fd2888eb188634051ba641ca3f57c2064c.tar.gz
gentoo-2-ce25c9fd2888eb188634051ba641ca3f57c2064c.tar.bz2
gentoo-2-ce25c9fd2888eb188634051ba641ca3f57c2064c.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.29.1.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 2eb2af07193c..a5650edfcc02 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.96 2014/05/20 23:20:00 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.97 2014/06/02 07:56:14 radhermit Exp $
+
+*boto-2.29.1 (02 Jun 2014)
+
+ 02 Jun 2014; Tim Harder <radhermit@gentoo.org> +boto-2.29.1.ebuild:
+ Version bump.
20 May 2014; Tim Harder <radhermit@gentoo.org> boto-2.27.0.ebuild:
Keywording amd64/x86 (bug #508570).
diff --git a/dev-python/boto/boto-2.29.1.ebuild b/dev-python/boto/boto-2.29.1.ebuild
new file mode 100644
index 000000000000..d782322be692
--- /dev/null
+++ b/dev-python/boto/boto-2.29.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.29.1.ebuild,v 1.1 2014/06/02 07:56:14 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}