summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Matejka <yac@gentoo.org>2013-04-28 22:40:33 +0000
committerJan Matejka <yac@gentoo.org>2013-04-28 22:40:33 +0000
commit8b9da237744879cb36df92849319ea3a7bfa4ff2 (patch)
tree241a6ce2bb9e7007c377513e7d3b0c00c220a9c9 /dev-python/cement/cement-2.0.2.ebuild
parentupdate license info (diff)
downloadgentoo-2-8b9da237744879cb36df92849319ea3a7bfa4ff2.tar.gz
gentoo-2-8b9da237744879cb36df92849319ea3a7bfa4ff2.tar.bz2
gentoo-2-8b9da237744879cb36df92849319ea3a7bfa4ff2.zip
New package dev-python/cement. Fixes bug 459580
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-python/cement/cement-2.0.2.ebuild')
-rw-r--r--dev-python/cement/cement-2.0.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/cement/cement-2.0.2.ebuild b/dev-python/cement/cement-2.0.2.ebuild
new file mode 100644
index 000000000000..d9fcb480fb74
--- /dev/null
+++ b/dev-python/cement/cement-2.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cement/cement-2.0.2.ebuild,v 1.1 2013/04/28 22:40:33 yac Exp $
+
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} )
+
+inherit distutils-r1 versionator
+
+PV_MAJOR_MINOR=`get_version_component_range 1-2`
+
+DESCRIPTION="CLI Application Framework for Python"
+HOMEPAGE="http://builtoncement.com/"
+SRC_URI="http://builtoncement.com/${PN}/${PV_MAJOR_MINOR}/source/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+
+
+DOCS=( ChangeLog CONTRIBUTORS README.md )
+PATCHES=( "${FILESDIR}"/tests-installation.patch )
+# https://github.com/cement/cement/issues/185
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_compile_all() {
+ if use doc; then
+ $PYTHON setup.py build_sphinx || die "couldn't build docs"
+ fi
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/build/html/* )
+
+ distutils-r1_python_install_all
+}