summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-11 08:13:30 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-11 08:13:30 +0000
commit86b0d154dd668a3857e2e408f9e1f2a2e57255e9 (patch)
tree079c8b3686976af16626ee84f9aa80705f4c21c0 /dev-python/chameleon
parentrm old (diff)
downloadgentoo-2-86b0d154dd668a3857e2e408f9e1f2a2e57255e9.tar.gz
gentoo-2-86b0d154dd668a3857e2e408f9e1f2a2e57255e9.tar.bz2
gentoo-2-86b0d154dd668a3857e2e408f9e1f2a2e57255e9.zip
bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/chameleon')
-rw-r--r--dev-python/chameleon/ChangeLog9
-rw-r--r--dev-python/chameleon/chameleon-2.19.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/chameleon/ChangeLog b/dev-python/chameleon/ChangeLog
index 3fabf8f8f3ad..38b400d0f627 100644
--- a/dev-python/chameleon/ChangeLog
+++ b/dev-python/chameleon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/chameleon
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.28 2014/12/28 10:06:31 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.29 2015/01/11 08:13:30 idella4 Exp $
+
+*chameleon-2.19 (11 Jan 2015)
+
+ 11 Jan 2015; Ian Delaney <idella4@gentoo.org> +chameleon-2.19.ebuild:
+ bump
28 Dec 2014; Agostino Sarubbo <ago@gentoo.org> chameleon-2.16.ebuild:
Stable for x86, wrt bug #531866
diff --git a/dev-python/chameleon/chameleon-2.19.ebuild b/dev-python/chameleon/chameleon-2.19.ebuild
new file mode 100644
index 000000000000..18a7f5dd525f
--- /dev/null
+++ b/dev-python/chameleon/chameleon-2.19.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/chameleon-2.19.ebuild,v 1.1 2015/01/11 08:13:30 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Chameleon"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="http://chameleon.repoze.org http://pypi.python.org/pypi/Chameleon"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( _build/html/{[a-z]*,_static} )
+
+ distutils-r1_python_install_all
+}