summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-09 09:17:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-09 09:17:59 +0000
commit6d1609c1b5ec02154ec37c75648f13e66b143174 (patch)
tree64b0dcffd230b6441796a9d789df8ec7b960227e /dev-python/colander
parentBump (diff)
downloadgentoo-2-6d1609c1b5ec02154ec37c75648f13e66b143174.tar.gz
gentoo-2-6d1609c1b5ec02154ec37c75648f13e66b143174.tar.bz2
gentoo-2-6d1609c1b5ec02154ec37c75648f13e66b143174.zip
Bump
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/colander')
-rw-r--r--dev-python/colander/ChangeLog8
-rw-r--r--dev-python/colander/colander-0.9.9.ebuild56
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-python/colander/ChangeLog b/dev-python/colander/ChangeLog
index 5c0a7b588c50..6ab71e5962b3 100644
--- a/dev-python/colander/ChangeLog
+++ b/dev-python/colander/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/colander
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/ChangeLog,v 1.7 2012/05/08 18:18:00 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/ChangeLog,v 1.8 2012/10/09 09:17:59 patrick Exp $
+
+*colander-0.9.9 (09 Oct 2012)
+
+ 09 Oct 2012; Patrick Lauer <patrick@gentoo.org> +colander-0.9.9.ebuild:
+ Bump
08 May 2012; Kacper Kowalik <xarthisius@gentoo.org> colander-0.9.8.ebuild:
Don't install sphinx's cache
@@ -32,4 +37,3 @@
30 Jul 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+colander-0.9.3.ebuild, +metadata.xml:
Initial version. Based on ebuild by Jan Matějka (bug #368019).
-
diff --git a/dev-python/colander/colander-0.9.9.ebuild b/dev-python/colander/colander-0.9.9.ebuild
new file mode 100644
index 000000000000..ea5764f5b52e
--- /dev/null
+++ b/dev-python/colander/colander-0.9.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/colander-0.9.9.ebuild,v 1.1 2012/10/09 09:17:59 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.6 3:3.2"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 3.1"
+DISTUTILS_SRC_TEST=nosetests
+
+inherit distutils
+
+DESCRIPTION="A simple schema-based serialization and deserialization library"
+HOMEPAGE="http://docs.pylonsproject.org/projects/colander/en/latest/ http://pypi.python.org/pypi/colander"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+# MIT license is used by included (modified) iso8601.py code.
+LICENSE="repoze MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+# Depend on an ebuild of translationstring with Python 3 support.
+RDEPEND=">=dev-python/translationstring-1.1"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS="CHANGES.txt COPYRIGHT.txt README.txt"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Remove pylons theme since it's not included in source
+ sed -e "/# Add and use Pylons theme/,+37d" -i docs/conf.py || die
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ # https://github.com/Pylons/colander/issues/38
+ PYTHONPATH="." emake -C docs html SPHINXOPTS=""
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/
+ fi
+}