summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2012-04-25 16:26:12 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2012-04-25 16:26:12 +0000
commit8d62ca2668dcbe353359beb28fdb94132a5e5e8d (patch)
treea3b7dd2dbddef625bf6c0349cf822726aae13c43 /dev-python/django-debug-toolbar
parentDrop unnessecary die (diff)
downloadgentoo-2-8d62ca2668dcbe353359beb28fdb94132a5e5e8d.tar.gz
gentoo-2-8d62ca2668dcbe353359beb28fdb94132a5e5e8d.tar.bz2
gentoo-2-8d62ca2668dcbe353359beb28fdb94132a5e5e8d.zip
Initial commit, ebuild by idella4
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/ChangeLog11
-rw-r--r--dev-python/django-debug-toolbar/Manifest4
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-0.9.4.ebuild42
-rw-r--r--dev-python/django-debug-toolbar/files/django-debug-toolbar-0.9.4-fix-with-py2.5.patch8
-rw-r--r--dev-python/django-debug-toolbar/metadata.xml14
5 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/ChangeLog b/dev-python/django-debug-toolbar/ChangeLog
new file mode 100644
index 000000000000..ca89eebf5ee7
--- /dev/null
+++ b/dev-python/django-debug-toolbar/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/django-debug-toolbar
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-debug-toolbar/ChangeLog,v 1.1 2012/04/25 16:26:12 tampakrap Exp $
+
+*django-debug-toolbar-0.9.4 (25 Apr 2012)
+
+ 25 Apr 2012; Theo Chatzimichos <tampakrap@gentoo.org>
+ +django-debug-toolbar-0.9.4.ebuild,
+ +files/django-debug-toolbar-0.9.4-fix-with-py2.5.patch, +metadata.xml:
+ Initial commit, ebuild by idella4
+
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
new file mode 100644
index 000000000000..415eb10da6f8
--- /dev/null
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -0,0 +1,4 @@
+AUX django-debug-toolbar-0.9.4-fix-with-py2.5.patch 445 RMD160 8e50d499e76a6f26de99dd842e16cf9481dc5de1 SHA1 d5da353afb45e718dc1c413bf3351d1d4b8905ad SHA256 b4abfac91fe846bd73e6f0ba753f2029fb31037e8c388e0d72d26943265ffe0c
+DIST django-debug-toolbar-0.9.4.tar.gz 150062 RMD160 ef7b0db00f1640787e6fefa611ae4e8643d5e7a3 SHA1 79a79a92509e9d4090b892c53711f63824744191 SHA256 d6bc217b672ddf0e729f76da2df1d4a50d45f1c934239851f7f7ae6a51201f4b
+EBUILD django-debug-toolbar-0.9.4.ebuild 922 RMD160 eee35acc9e601f46deeda3c12769ddbed6206e25 SHA1 0286f4725031f0b76c32f7c88b47a9c23a962615 SHA256 dbf8d93bb5292ed3a9eee18d6a61a04c344ddb429a28c5b395473851e2eea6c8
+MISC metadata.xml 354 RMD160 091888911fc3977462b1015a07a860a68ab6ee9e SHA1 dfd9a92e0cdac92fbeccaae8038db941a4273b09 SHA256 286b386bcfeeacbeace854ed0f9904d845b8397b957963d95bae64534a6decb2
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-0.9.4.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-0.9.4.ebuild
new file mode 100644
index 000000000000..7a2a812c384c
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-0.9.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-debug-toolbar/django-debug-toolbar-0.9.4.ebuild,v 1.1 2012/04/25 16:26:12 tampakrap Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="http://pypi.python.org/pypi/django-debug-toolbar/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+LICENSE="MIT"
+SLOT="0"
+PYTHON_MODNAME="debug_toolbar"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ dev-python/django
+ test? ( dev-python/dingus )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-with-py2.5.patch
+}
+
+src_test() {
+ export DJANGO_SETTINGS_MODULE="django.conf"
+ testing() {
+ PYTHONPATH=. "$(PYTHON)" tests/tests.py
+ if [[ $? ]]; then
+ einfo "Tests for python"$(python_get_version)" completed ok"
+ einfo ""
+ fi
+ }
+ python_execute_function testing
+}
diff --git a/dev-python/django-debug-toolbar/files/django-debug-toolbar-0.9.4-fix-with-py2.5.patch b/dev-python/django-debug-toolbar/files/django-debug-toolbar-0.9.4-fix-with-py2.5.patch
new file mode 100644
index 000000000000..9e26d395ccb4
--- /dev/null
+++ b/dev-python/django-debug-toolbar/files/django-debug-toolbar-0.9.4-fix-with-py2.5.patch
@@ -0,0 +1,8 @@
+diff -ur django-debug-toolbar-0.9.4.orig/tests/tests.py django-debug-toolbar-0.9.4/tests/tests.py
+--- tests/tests.py 2011-10-10 02:47:15.000000000 +0800
++++ tests/tests.py 2012-04-25 22:00:50.956680910 +0800
+@@ -1,3 +1,4 @@
++from __future__ import with_statement
+ from debug_toolbar.middleware import DebugToolbarMiddleware
+ from debug_toolbar.panels.sql import SQLDebugPanel
+ from debug_toolbar.panels.request_vars import RequestVarsDebugPanel
diff --git a/dev-python/django-debug-toolbar/metadata.xml b/dev-python/django-debug-toolbar/metadata.xml
new file mode 100644
index 000000000000..472ba4684030
--- /dev/null
+++ b/dev-python/django-debug-toolbar/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>johneed@hotmail.com</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <maintainer>
+ <email>tampakrap@gentoo.org</email>
+ <name>Theo Chatzimichos</name>
+ </maintainer>
+ <herd>python</herd>
+</pkgmetadata>
+