summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-04-12 01:37:51 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-04-12 01:37:51 +0000
commite696cf9b73e002fbbce3b5e11ad02bbd018a669d (patch)
treea9c9a9239be87b2430d0e36a9555213ed7178bda /dev-python/django-openstack-auth
parentAdd python3.3. (diff)
downloadgentoo-2-e696cf9b73e002fbbce3b5e11ad02bbd018a669d.tar.gz
gentoo-2-e696cf9b73e002fbbce3b5e11ad02bbd018a669d.tar.bz2
gentoo-2-e696cf9b73e002fbbce3b5e11ad02bbd018a669d.zip
initial of commit django_openstack_auth for horizon
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/django-openstack-auth')
-rw-r--r--dev-python/django-openstack-auth/ChangeLog9
-rw-r--r--dev-python/django-openstack-auth/Manifest3
-rw-r--r--dev-python/django-openstack-auth/django-openstack-auth-1.0.7.ebuild24
-rw-r--r--dev-python/django-openstack-auth/metadata.xml13
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/django-openstack-auth/ChangeLog b/dev-python/django-openstack-auth/ChangeLog
new file mode 100644
index 000000000000..9aba675c75e8
--- /dev/null
+++ b/dev-python/django-openstack-auth/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/django-openstack-auth
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-openstack-auth/ChangeLog,v 1.1 2013/04/12 01:37:51 prometheanfire Exp $
+
+*django-openstack-auth-1.0.7 (12 Apr 2013)
+
+ 12 Apr 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +django-openstack-auth-1.0.7.ebuild, +metadata.xml:
+ initial of commit django_openstack_auth for horizon
diff --git a/dev-python/django-openstack-auth/Manifest b/dev-python/django-openstack-auth/Manifest
new file mode 100644
index 000000000000..8cb91330ddd5
--- /dev/null
+++ b/dev-python/django-openstack-auth/Manifest
@@ -0,0 +1,3 @@
+DIST django_openstack_auth-1.0.7.tar.gz 21857 SHA256 6486f7da5f5b49c669d81204be133ca3c6181fea8b8a2f4142b1dc823c1dc198 SHA512 62449f1eea8a77fcc1c11197da073e0925e4d4a705506c92cd22896cd00d4eff22dbe35cc4b6f4529c79a9184fe5fc6a5462f32ae24d68b6c21c0bf123723dc9 WHIRLPOOL c4e6c89a0948082e36359860882f0595809e15208f3f972397230f9e1f80d32182bcbc02d7d4473fd01d0ede73a479a35c090f1ecc985d334b7c56c2b9f073c6
+EBUILD django-openstack-auth-1.0.7.ebuild 865 SHA256 d8f9ee4882d36bd33d5b6193c5a1d3d13ffe37ac0aba73636ba1a8236b1f4c5a SHA512 f5ec5b248f86c73a474afdac4dbbea9b89d32838b11e3d871673ff1e3460a287095921be4bf2763bc92f58c5fec13cfbda3b82002be12b6f87bc71cfd1231e40 WHIRLPOOL c513ff3931af2afe7aeb808a3e0a957aeec0d2b1540334c54488781a4d80eed8de4426f6f56de877ddbd79ab37a81b26e7dce29f9a157576f0487aba5213edf9
+MISC metadata.xml 410 SHA256 66c13e34074b826099e5498014c02ff52c36d6b190e064c838460daa7507387e SHA512 392bc0e4c79aeacfa7d9c2ebf132152cc12ae08e17a1790303962a4cafeeccc72d47c751c5c23816302ac22bf1636039d880a9ee18a0443911f78d50a3200590 WHIRLPOOL 6a2adb547532af43875a839d536c2d2e30ea7d80edb977c2b5bc63d803fea6100ea381fcf5d3ecf5480d8b27a6180ff5812e20c3943fbe3fc1fe7d2b05ceeca1
diff --git a/dev-python/django-openstack-auth/django-openstack-auth-1.0.7.ebuild b/dev-python/django-openstack-auth/django-openstack-auth-1.0.7.ebuild
new file mode 100644
index 000000000000..748e5b324dfa
--- /dev/null
+++ b/dev-python/django-openstack-auth/django-openstack-auth-1.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-openstack-auth/django-openstack-auth-1.0.7.ebuild,v 1.1 2013/04/12 01:37:51 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django authentication backend for use with the OpenStack Keystone
+Identity backend."
+HOMEPAGE="http://django_openstack_auth.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/django_openstack_auth/django_openstack_auth-${PV}.tar.gz"
+S="${WORKDIR}/django_openstack_auth-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mox[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/python-keystoneclient-0.2[${PYTHON_USEDEP}]
+ >=dev-python/django-1.4[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-openstack-auth/metadata.xml b/dev-python/django-openstack-auth/metadata.xml
new file mode 100644
index 000000000000..e2c69659d400
--- /dev/null
+++ b/dev-python/django-openstack-auth/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Django authentication backend for use with the OpenStack Keystone Identity backend.
+ </longdescription>
+</pkgmetadata>
+