summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-02-01 16:29:03 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-02-01 16:29:03 +0000
commit22649b171c7a5145f3baa6a668f9078320c94060 (patch)
tree126d8b401d8ecc960af5994fab1c25d8b392681d /dev-python/docutils
parentRemove old. (diff)
downloadgentoo-2-22649b171c7a5145f3baa6a668f9078320c94060.tar.gz
gentoo-2-22649b171c7a5145f3baa6a668f9078320c94060.tar.bz2
gentoo-2-22649b171c7a5145f3baa6a668f9078320c94060.zip
Remove old.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-python/docutils')
-rw-r--r--dev-python/docutils/ChangeLog6
-rw-r--r--dev-python/docutils/docutils-0.8.1.ebuild119
-rw-r--r--dev-python/docutils/docutils-0.9.1.ebuild119
-rw-r--r--dev-python/docutils/docutils-0.9.ebuild110
4 files changed, 5 insertions, 349 deletions
diff --git a/dev-python/docutils/ChangeLog b/dev-python/docutils/ChangeLog
index 8cfba21fbae5..69ee9cc0681d 100644
--- a/dev-python/docutils/ChangeLog
+++ b/dev-python/docutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/docutils
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/ChangeLog,v 1.211 2015/01/05 09:15:14 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/ChangeLog,v 1.212 2015/02/01 16:29:03 mrueg Exp $
+
+ 01 Feb 2015; Manuel Rüger <mrueg@gentoo.org> -docutils-0.8.1.ebuild,
+ -docutils-0.9.1.ebuild, -docutils-0.9.ebuild:
+ Remove old.
05 Jan 2015; Yixun Lan <dlan@gentoo.org> docutils-0.12.ebuild:
keyword ~arm64, test on board
diff --git a/dev-python/docutils/docutils-0.8.1.ebuild b/dev-python/docutils/docutils-0.8.1.ebuild
deleted file mode 100644
index ef7a6dc17fe4..000000000000
--- a/dev-python/docutils/docutils-0.8.1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/docutils-0.8.1.ebuild,v 1.11 2012/10/07 00:44:32 floppym Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*::3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.3"
-
-inherit distutils eutils
-
-DESCRIPTION="Docutils - Python Documentation Utilities"
-HOMEPAGE="http://docutils.sourceforge.net/ http://pypi.python.org/pypi/docutils"
-if [[ "${PV}" == *_pre* ]]; then
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-fi
-SRC_URI+=" glep? ( mirror://gentoo/glep-0.4-r1.tbz2 )"
-
-LICENSE="BSD-2 GPL-3 PSF-2 public-domain"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="glep"
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-DOCS="*.txt"
-PYTHON_MODNAME="docutils roman.py"
-
-GLEP_SRC="${WORKDIR}/glep-0.4-r1"
-
-src_prepare() {
- # Fix installation of extra modules.
- epatch "${FILESDIR}/${PN}-0.6-extra_modules.patch"
-
- sed -e "s/from distutils.core/from setuptools/" -i setup.py || die "sed setup.py failed"
-}
-
-src_compile() {
- distutils_src_compile
-
- # Generate html docs from reStructured text sources.
-
- # Make roman.py available for process of building of documentation.
- ln -s extras/roman.py
-
- # Place html4css1.css in base directory to ensure that the generated reference to it is correct.
- cp docutils/writers/html4css1/html4css1.css .
-
- pushd tools > /dev/null
-
- echo PYTHONPATH="../build-$(PYTHON -f --ABI)/lib" "$(PYTHON -f)" $([[ -f ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py ]] && echo ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py || echo ../tools/buildhtml.py) --input-encoding=utf-8 --stylesheet-path=../html4css1.css --traceback ../docs
- PYTHONPATH="../build-$(PYTHON -f --ABI)/lib" "$(PYTHON -f)" $([[ -f ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py ]] && echo ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py || echo ../tools/buildhtml.py) --input-encoding=utf-8 --stylesheet-path=../html4css1.css --traceback ../docs || die "buildhtml.py failed"
-
- popd > /dev/null
-
- # Clean up after building of documentation.
- rm roman.py html4css1.css
-}
-
-src_test() {
- testing() {
- echo PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" $([[ -f build-${PYTHON_ABI}/lib/test/alltests.py ]] && echo build-${PYTHON_ABI}/lib/test/alltests.py || echo test/alltests.py)
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" $([[ -f build-${PYTHON_ABI}/lib/test/alltests.py ]] && echo build-${PYTHON_ABI}/lib/test/alltests.py || echo test/alltests.py)
- }
- python_execute_function testing
-}
-
-install_txt_doc() {
- local doc="${1}"
- local dir="txt/$(dirname ${doc})"
- docinto "${dir}"
- dodoc "${doc}"
-}
-
-src_install() {
- distutils_src_install
-
- postinstallational_preparation() {
- # Install tools.
- mkdir -p "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
- pushd $([[ -d build-${PYTHON_ABI}/lib/tools ]] && echo build-${PYTHON_ABI}/lib/tools || echo tools) > /dev/null
- cp buildhtml.py quicktest.py "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
- popd > /dev/null
-
- # Delete useless files, which are installed only with Python 3.
- rm -fr "${ED}$(python_get_sitedir)/"{test,tools}
- }
- python_execute_function -q postinstallational_preparation
- python_merge_intermediate_installation_images "${T}/images"
-
- # Install documentation.
- dohtml -r docs tools
-
- # Install stylesheet file.
- insinto /usr/share/doc/${PF}/html
- doins docutils/writers/html4css1/html4css1.css
- local doc
- for doc in $(find docs tools -name "*.txt"); do
- install_txt_doc "${doc}"
- done
-
- # Install Gentoo GLEP tools.
- if use glep; then
- dobin "${GLEP_SRC}/glep.py" || die "dobin failed"
-
- installation_of_glep_tools() {
- insinto $(python_get_sitedir)/docutils/readers
- newins "${GLEP_SRC}/glepread.py" glep.py || die "newins reader failed"
- insinto $(python_get_sitedir)/docutils/transforms
- newins "${GLEP_SRC}/glepstrans.py" gleps.py || die "newins transform failed"
- insinto $(python_get_sitedir)/docutils/writers
- doins -r "${GLEP_SRC}/glep_html" || die "doins writer failed"
- }
- python_execute_function --action-message 'Installation of GLEP tools with $(python_get_implementation_and_version)...' installation_of_glep_tools
- fi
-}
diff --git a/dev-python/docutils/docutils-0.9.1.ebuild b/dev-python/docutils/docutils-0.9.1.ebuild
deleted file mode 100644
index 847bc9a62388..000000000000
--- a/dev-python/docutils/docutils-0.9.1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/docutils-0.9.1.ebuild,v 1.12 2013/01/04 21:56:30 ago Exp $
-
-EAPI="4"
-PYTHON_DEPEND="*::3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.3"
-
-inherit distutils
-
-DESCRIPTION="Docutils - Python Documentation Utilities"
-HOMEPAGE="http://docutils.sourceforge.net/ http://pypi.python.org/pypi/docutils"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SRC_URI+=" glep? ( mirror://gentoo/glep-0.4-r1.tbz2 )"
-
-LICENSE="BSD-2 GPL-3 public-domain"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="glep"
-
-RDEPEND="dev-python/pygments"
-DEPEND="${RDEPEND}"
-
-DOCS="*.txt"
-
-GLEP_SRC="${WORKDIR}/glep-0.4-r1"
-
-src_compile() {
- distutils_src_compile
-
- # Generate html docs from reStructured text sources.
-
- # Place html4css1.css in base directory to ensure that the generated reference to it is correct.
- cp docutils/writers/html4css1/html4css1.css .
-
- pushd tools > /dev/null
-
- PYTHONPATH="../build-$(PYTHON -f --ABI)/lib" "$(PYTHON -f)" \
- ../tools/buildhtml.py --input-encoding=utf-8 \
- --stylesheet-path=../html4css1.css --traceback ../docs || die
-
- popd > /dev/null
-
- # Clean up after building of documentation.
- rm html4css1.css
-}
-
-src_test() {
- testing() {
- local testfile=test/alltests.py
- if [[ $(python_get_version --language --major) == 3 ]]; then
- testfile=test3/alltests.py
- fi
- echo PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" "${testfile}"
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" "${testfile}"
- }
- python_execute_function testing
-}
-
-install_txt_doc() {
- local doc="${1}"
- local dir="txt/$(dirname ${doc})"
- docinto "${dir}"
- dodoc "${doc}"
-}
-
-src_install() {
- distutils_src_install
-
- postinstallational_preparation() {
- # Install tools.
- mkdir -p "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
- cp tools/{buildhtml,quicktest}.py \
- "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
- }
- python_execute_function -q postinstallational_preparation
- python_merge_intermediate_installation_images "${T}/images"
-
- # Install documentation.
- dohtml -r docs tools
-
- # Install stylesheet file.
- insinto /usr/share/doc/${PF}/html
- doins docutils/writers/html4css1/html4css1.css
- local doc
- for doc in $(find docs tools -name "*.txt"); do
- install_txt_doc "${doc}"
- done
-
- # Install Gentoo GLEP tools.
- if use glep; then
- dobin "${GLEP_SRC}/glep.py"
-
- installation_of_glep_tools() {
- insinto $(python_get_sitedir)/docutils/readers
- newins "${GLEP_SRC}/glepread.py" glep.py
- insinto $(python_get_sitedir)/docutils/transforms
- newins "${GLEP_SRC}/glepstrans.py" gleps.py
- insinto $(python_get_sitedir)/docutils/writers
- doins -r "${GLEP_SRC}/glep_html"
- }
- python_execute_function --action-message 'Installation of GLEP tools with $(python_get_implementation_and_version)' installation_of_glep_tools
- fi
-}
-
-pkg_preinst() {
- # Remove egg-info directory left over from setuptools.
- [[ ${PV} == 0.9.1 ]] || die "pkg_preinst no longer needed"
- remove_egg_info() {
- local lv="$(python_get_version --language)"
- local sitedir="$(python_get_sitedir --base-path)"
- local egg_info="${ROOT}${sitedir}/${P}-py${lv}.egg-info"
- if [[ -d "${egg_info}" ]]; then
- rm -r "${egg_info}"
- fi
- }
- python_execute_function -q remove_egg_info
-}
diff --git a/dev-python/docutils/docutils-0.9.ebuild b/dev-python/docutils/docutils-0.9.ebuild
deleted file mode 100644
index a1e9c7c70638..000000000000
--- a/dev-python/docutils/docutils-0.9.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/docutils-0.9.ebuild,v 1.5 2012/10/07 00:44:32 floppym Exp $
-
-EAPI="4"
-PYTHON_DEPEND="*::3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.3"
-
-inherit distutils
-
-DESCRIPTION="Docutils - Python Documentation Utilities"
-HOMEPAGE="http://docutils.sourceforge.net/ http://pypi.python.org/pypi/docutils"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SRC_URI+=" glep? ( mirror://gentoo/glep-0.4-r1.tbz2 )"
-
-LICENSE="BSD-2 GPL-3 public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="glep"
-
-RDEPEND="dev-python/pygments"
-DEPEND="dev-python/setuptools
- ${RDEPEND}"
-
-DOCS="*.txt"
-
-GLEP_SRC="${WORKDIR}/glep-0.4-r1"
-
-src_prepare() {
- distutils_src_prepare
- sed -e "s/from distutils.core/from setuptools/" -i setup.py || die "sed setup.py failed"
-}
-
-src_compile() {
- distutils_src_compile
-
- # Generate html docs from reStructured text sources.
-
- # Place html4css1.css in base directory to ensure that the generated reference to it is correct.
- cp docutils/writers/html4css1/html4css1.css .
-
- pushd tools > /dev/null
-
- echo PYTHONPATH="../build-$(PYTHON -f --ABI)/lib" "$(PYTHON -f)" $([[ -f ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py ]] && echo ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py || echo ../tools/buildhtml.py) --input-encoding=utf-8 --stylesheet-path=../html4css1.css --traceback ../docs
- PYTHONPATH="../build-$(PYTHON -f --ABI)/lib" "$(PYTHON -f)" $([[ -f ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py ]] && echo ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py || echo ../tools/buildhtml.py) --input-encoding=utf-8 --stylesheet-path=../html4css1.css --traceback ../docs || die "buildhtml.py failed"
-
- popd > /dev/null
-
- # Clean up after building of documentation.
- rm html4css1.css
-}
-
-src_test() {
- testing() {
- echo PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" $([[ -f build-${PYTHON_ABI}/lib/test/alltests.py ]] && echo build-${PYTHON_ABI}/lib/test/alltests.py || echo test/alltests.py)
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" $([[ -f build-${PYTHON_ABI}/lib/test/alltests.py ]] && echo build-${PYTHON_ABI}/lib/test/alltests.py || echo test/alltests.py)
- }
- python_execute_function testing
-}
-
-install_txt_doc() {
- local doc="${1}"
- local dir="txt/$(dirname ${doc})"
- docinto "${dir}"
- dodoc "${doc}"
-}
-
-src_install() {
- distutils_src_install
-
- postinstallational_preparation() {
- # Install tools.
- mkdir -p "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
- pushd $([[ -d build-${PYTHON_ABI}/lib/tools ]] && echo build-${PYTHON_ABI}/lib/tools || echo tools) > /dev/null
- cp buildhtml.py quicktest.py "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
- popd > /dev/null
-
- # Delete useless files, which are installed only with Python 3.
- rm -fr "${ED}$(python_get_sitedir)/"{test,tools}
- }
- python_execute_function -q postinstallational_preparation
- python_merge_intermediate_installation_images "${T}/images"
-
- # Install documentation.
- dohtml -r docs tools
-
- # Install stylesheet file.
- insinto /usr/share/doc/${PF}/html
- doins docutils/writers/html4css1/html4css1.css
- local doc
- for doc in $(find docs tools -name "*.txt"); do
- install_txt_doc "${doc}"
- done
-
- # Install Gentoo GLEP tools.
- if use glep; then
- dobin "${GLEP_SRC}/glep.py"
-
- installation_of_glep_tools() {
- insinto $(python_get_sitedir)/docutils/readers
- newins "${GLEP_SRC}/glepread.py" glep.py
- insinto $(python_get_sitedir)/docutils/transforms
- newins "${GLEP_SRC}/glepstrans.py" gleps.py
- insinto $(python_get_sitedir)/docutils/writers
- doins -r "${GLEP_SRC}/glep_html"
- }
- python_execute_function --action-message 'Installation of GLEP tools with $(python_get_implementation_and_version)' installation_of_glep_tools
- fi
-}