summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-06-03 06:02:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-06-03 06:02:41 +0000
commit1670b0b7fda3aa48bcc3063c6c965634a4fb89bd (patch)
treea58e5023b508e629ebb9fac6a1ba1b8f588d5f9e /dev-python/dpkt
parentBump (diff)
downloadgentoo-2-1670b0b7fda3aa48bcc3063c6c965634a4fb89bd.tar.gz
gentoo-2-1670b0b7fda3aa48bcc3063c6c965634a4fb89bd.tar.bz2
gentoo-2-1670b0b7fda3aa48bcc3063c6c965634a4fb89bd.zip
Bump
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/dpkt')
-rw-r--r--dev-python/dpkt/ChangeLog10
-rw-r--r--dev-python/dpkt/dpkt-1.8.ebuild40
2 files changed, 47 insertions, 3 deletions
diff --git a/dev-python/dpkt/ChangeLog b/dev-python/dpkt/ChangeLog
index 3e457c9b6a45..0dfd6d3d46fe 100644
--- a/dev-python/dpkt/ChangeLog
+++ b/dev-python/dpkt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dpkt
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dpkt/ChangeLog,v 1.4 2010/07/01 01:35:31 arfrever Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dpkt/ChangeLog,v 1.5 2013/06/03 06:02:41 patrick Exp $
+
+*dpkt-1.8 (03 Jun 2013)
+
+ 03 Jun 2013; Patrick Lauer <patrick@gentoo.org> +dpkt-1.8.ebuild:
+ Bump
*dpkt-1.7 (01 Jul 2010)
@@ -18,4 +23,3 @@
06 Feb 2007; Tiziano Müller <dev-zero@gentoo.org> +dpkt-1.6.ebuild,
+metadata.xml:
New ebuild for bug #165530 (thanks to Santiago M. Mola Velasco).
-
diff --git a/dev-python/dpkt/dpkt-1.8.ebuild b/dev-python/dpkt/dpkt-1.8.ebuild
new file mode 100644
index 000000000000..7b98f4c7161a
--- /dev/null
+++ b/dev-python/dpkt/dpkt-1.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dpkt/dpkt-1.8.ebuild,v 1.1 2013/06/03 06:02:41 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Fast, simple packet creation / parsing, with definitions for the basic TCP/IP protocols."
+HOMEPAGE="http://code.google.com/p/dpkt/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="AUTHORS CHANGES HACKING"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/test-perf2.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}