summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-09 09:22:56 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-09 09:22:56 +0000
commit90f9347c41a50a8744046db649a71740254dd80c (patch)
treebb7b86176077f44286c749f69692b43cdce33b17 /dev-python/enable
parentBump (diff)
downloadgentoo-2-90f9347c41a50a8744046db649a71740254dd80c.tar.gz
gentoo-2-90f9347c41a50a8744046db649a71740254dd80c.tar.bz2
gentoo-2-90f9347c41a50a8744046db649a71740254dd80c.zip
Bump
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/enable')
-rw-r--r--dev-python/enable/ChangeLog7
-rw-r--r--dev-python/enable/enable-4.2.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/enable/ChangeLog b/dev-python/enable/ChangeLog
index 2e81bd0bfe3b..822be90c2be1 100644
--- a/dev-python/enable/ChangeLog
+++ b/dev-python/enable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/enable
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.17 2012/08/07 04:03:10 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.18 2012/10/09 09:22:56 patrick Exp $
+
+*enable-4.2.0 (09 Oct 2012)
+
+ 09 Oct 2012; Patrick Lauer <patrick@gentoo.org> +enable-4.2.0.ebuild:
+ Bump
07 Aug 2012; Patrick Lauer <patrick@gentoo.org> enable-4.1.0.ebuild:
Restricting py-2.5
diff --git a/dev-python/enable/enable-4.2.0.ebuild b/dev-python/enable/enable-4.2.0.ebuild
new file mode 100644
index 000000000000..e1f8fa18c1a5
--- /dev/null
+++ b/dev-python/enable/enable-4.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-4.2.0.ebuild,v 1.1 2012/10/09 09:22:56 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-* 2.5"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
+HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/enable"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/numpy
+ dev-python/reportlab
+ >=dev-python/traitsui-4
+ >=media-libs/freetype-2
+ virtual/opengl
+ x11-libs/libX11"
+DEPEND="dev-python/setuptools
+ dev-lang/swig
+ dev-python/cython
+ doc? ( dev-python/sphinx )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+DOCS="docs/*.txt"
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}