summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 17:56:45 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 17:56:45 +0000
commitf62e5e99f321a4fde71e4fac52b032eb80eec8f8 (patch)
treee3ab6c7010cabb594dad453e200e7d5a4a2d58a1 /dev-python/envisagecore
parentalpha/ia64/sparc stable wrt #352730 (diff)
downloadgentoo-2-f62e5e99f321a4fde71e4fac52b032eb80eec8f8.tar.gz
gentoo-2-f62e5e99f321a4fde71e4fac52b032eb80eec8f8.tar.bz2
gentoo-2-f62e5e99f321a4fde71e4fac52b032eb80eec8f8.zip
Version bump.
(Portage version: 2.2.0_alpha19_p24/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/envisagecore')
-rw-r--r--dev-python/envisagecore/ChangeLog10
-rw-r--r--dev-python/envisagecore/envisagecore-3.2.0.ebuild72
2 files changed, 80 insertions, 2 deletions
diff --git a/dev-python/envisagecore/ChangeLog b/dev-python/envisagecore/ChangeLog
index a4210c34b776..1b51ca1c6f8f 100644
--- a/dev-python/envisagecore/ChangeLog
+++ b/dev-python/envisagecore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/envisagecore
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/envisagecore/ChangeLog,v 1.7 2010/10/18 14:34:38 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisagecore/ChangeLog,v 1.8 2011/01/30 17:56:45 arfrever Exp $
+
+*envisagecore-3.2.0 (30 Jan 2011)
+
+ 30 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -envisagecore-3.1.3.ebuild, +envisagecore-3.2.0.ebuild:
+ Version bump.
*envisagecore-3.1.3 (18 Oct 2010)
diff --git a/dev-python/envisagecore/envisagecore-3.2.0.ebuild b/dev-python/envisagecore/envisagecore-3.2.0.ebuild
new file mode 100644
index 000000000000..19cf72a7ad78
--- /dev/null
+++ b/dev-python/envisagecore/envisagecore-3.2.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/envisagecore/envisagecore-3.2.0.ebuild,v 1.1 2011/01/30 17:56:45 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils virtualx
+
+MY_PN="EnvisageCore"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Enthought Tool Suite: Extensible application framework"
+HOMEPAGE="http://code.enthought.com/projects/envisage/ http://pypi.python.org/pypi/EnvisageCore"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/apptools-3.4.1
+ >=dev-python/enthoughtbase-3.1.0
+ >=dev-python/traits-3.6.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/coverage
+ dev-python/nose
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="enthought"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ maketype="distutils_src_test" virtualmake
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}