summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2009-02-10 08:03:07 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2009-02-10 08:03:07 +0000
commit215abf67747d7a1cc1df72ccfaed8968de1a7c46 (patch)
tree644f2ad4d6f7e25d53ce09f2081cabd1a9405add /dev-python/epsilon
parentVersion bump. (diff)
downloadgentoo-2-215abf67747d7a1cc1df72ccfaed8968de1a7c46.tar.gz
gentoo-2-215abf67747d7a1cc1df72ccfaed8968de1a7c46.tar.bz2
gentoo-2-215abf67747d7a1cc1df72ccfaed8968de1a7c46.zip
version bump
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/epsilon')
-rw-r--r--dev-python/epsilon/ChangeLog10
-rw-r--r--dev-python/epsilon/epsilon-0.5.11.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-python/epsilon/ChangeLog b/dev-python/epsilon/ChangeLog
index a302804eda99..7df3e06f5c41 100644
--- a/dev-python/epsilon/ChangeLog
+++ b/dev-python/epsilon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/epsilon
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/ChangeLog,v 1.10 2008/04/04 05:14:42 lordvan Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/ChangeLog,v 1.11 2009/02/10 08:03:07 lordvan Exp $
+
+*epsilon-0.5.11 (10 Feb 2009)
+
+ 10 Feb 2009; Thomas Raschbacher <lordvan@gentoo.org>
+ +epsilon-0.5.11.ebuild:
+ version bump
*epsilon-0.5.9 (04 Apr 2008)
diff --git a/dev-python/epsilon/epsilon-0.5.11.ebuild b/dev-python/epsilon/epsilon-0.5.11.ebuild
new file mode 100644
index 000000000000..bd6c57058cd2
--- /dev/null
+++ b/dev-python/epsilon/epsilon-0.5.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/epsilon-0.5.11.ebuild,v 1.1 2009/02/10 08:03:07 lordvan Exp $
+
+inherit distutils
+
+DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class."
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodEpsilon"
+SRC_URI="mirror://gentoo/Epsilon-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~ia64 ~ppc64 ~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4
+ >=dev-python/twisted-2.4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Epsilon-${PV}"
+
+DOCS="NAME.txt NEWS.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Rename to avoid file-collisions
+ mv bin/benchmark bin/epsilon-benchmark
+ sed -i \
+ -e "s#bin/benchmark#bin/epsilon-benchmark#" \
+ setup.py || die "sed failed"
+}
+
+src_compile() {
+ # skip this, or epsilon will install the temporary "build" dir
+ true
+}
+
+src_test() {
+ # release tests needs DivmodCombinator
+ rm epsilon/test/test_release.py*
+ PYTHONPATH=. trial epsilon || die "tests failed"
+}