summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-10-25 04:09:17 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-10-25 04:09:17 +0000
commit3d324a6b0ca5c4bae27c5d97abcad7852869488e (patch)
treebbf98a58b650c3fefce34dfbd74cada0bb7e132c /dev-python/expects
parentadd version 0.8.2 (diff)
downloadgentoo-2-3d324a6b0ca5c4bae27c5d97abcad7852869488e.tar.gz
gentoo-2-3d324a6b0ca5c4bae27c5d97abcad7852869488e.tar.bz2
gentoo-2-3d324a6b0ca5c4bae27c5d97abcad7852869488e.zip
add version 0.4.2 and 0.5.0
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python/expects')
-rw-r--r--dev-python/expects/ChangeLog9
-rw-r--r--dev-python/expects/expects-0.4.2.ebuild41
-rw-r--r--dev-python/expects/expects-0.5.0.ebuild38
3 files changed, 87 insertions, 1 deletions
diff --git a/dev-python/expects/ChangeLog b/dev-python/expects/ChangeLog
index c6f76614df41..5cf89f866afe 100644
--- a/dev-python/expects/ChangeLog
+++ b/dev-python/expects/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/expects
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/expects/ChangeLog,v 1.2 2014/10/18 14:45:35 alunduil Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/expects/ChangeLog,v 1.3 2014/10/25 04:09:17 alunduil Exp $
+
+*expects-0.5.0 (25 Oct 2014)
+*expects-0.4.2 (25 Oct 2014)
+
+ 25 Oct 2014; Alex Brandt <alunduil@gentoo.org> +expects-0.4.2.ebuild,
+ +expects-0.5.0.ebuild:
+ add version 0.4.2 and 0.5.0
18 Oct 2014; Alex Brandt <alunduil@gentoo.org> expects-0.2.1.ebuild:
add missing dependence on dev-python/setuptools
diff --git a/dev-python/expects/expects-0.4.2.ebuild b/dev-python/expects/expects-0.4.2.ebuild
new file mode 100644
index 000000000000..11fa97e83c16
--- /dev/null
+++ b/dev-python/expects/expects-0.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/expects/expects-0.4.2.ebuild,v 1.1 2014/10/25 04:09:17 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Expressive and extensible TDD/BDD assertion library for Python"
+HOMEPAGE="https://github.com/jaimegildesagredo/expects"
+SRC_URI="https://github.com/jaimegildesagredo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ >=dev-python/mamba-0.8.2[${PYTHON_USEDEP}]
+ <dev-python/mamba-0.9[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ mamba || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/expects/expects-0.5.0.ebuild b/dev-python/expects/expects-0.5.0.ebuild
new file mode 100644
index 000000000000..8ecb9826b476
--- /dev/null
+++ b/dev-python/expects/expects-0.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/expects/expects-0.5.0.ebuild,v 1.1 2014/10/25 04:09:17 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Expressive and extensible TDD/BDD assertion library for Python"
+HOMEPAGE="https://github.com/jaimegildesagredo/expects"
+SRC_URI="https://github.com/jaimegildesagredo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( >=dev-python/mamba-0.8.2[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ mamba || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}