summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-20 01:50:33 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-20 01:50:33 +0000
commitd64b996350518c63205c877e0430927795328777 (patch)
treed29f2b22848d94537b39a2eadaba0266cded4602 /dev-python/flask-restless
parentrm old, tidy to doc install (diff)
downloadgentoo-2-d64b996350518c63205c877e0430927795328777.tar.gz
gentoo-2-d64b996350518c63205c877e0430927795328777.tar.bz2
gentoo-2-d64b996350518c63205c877e0430927795328777.zip
rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-restless')
-rw-r--r--dev-python/flask-restless/ChangeLog6
-rw-r--r--dev-python/flask-restless/flask-restless-0.14.1.ebuild60
-rw-r--r--dev-python/flask-restless/flask-restless-0.14.2.ebuild60
-rw-r--r--dev-python/flask-restless/flask-restless-0.15.1.ebuild60
4 files changed, 5 insertions, 181 deletions
diff --git a/dev-python/flask-restless/ChangeLog b/dev-python/flask-restless/ChangeLog
index 8431a5c19784..553352af040f 100644
--- a/dev-python/flask-restless/ChangeLog
+++ b/dev-python/flask-restless/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/flask-restless
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.24 2015/03/16 04:04:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.25 2015/03/20 01:50:33 idella4 Exp $
+
+ 20 Mar 2015; Ian Delaney <idella4@gentoo.org> -flask-restless-0.14.1.ebuild,
+ -flask-restless-0.14.2.ebuild, -flask-restless-0.15.1.ebuild:
+ rm old
*flask-restless-0.17.0 (16 Mar 2015)
diff --git a/dev-python/flask-restless/flask-restless-0.14.1.ebuild b/dev-python/flask-restless/flask-restless-0.14.1.ebuild
deleted file mode 100644
index 494f7aaf5174..000000000000
--- a/dev-python/flask-restless/flask-restless-0.14.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.14.1.ebuild,v 1.1 2015/01/30 06:56:19 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-PYTHON_REQ_USE="sqlite"
-inherit distutils-r1
-
-DESCRIPTION="Flask extension for easy ReSTful API generation"
-HOMEPAGE="http://packages.python.org/Flask-Restless/"
-SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( AGPL-3 BSD )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/mimerender[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
- dev-python/flask-themes[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/mapping.patch )
-
-python_compile_all() {
- if use doc; then
- if ! "${PYTHON}" -c "import flask_restless"; then
- eerror "flask-restless is not installed. Building of the docs"
- eerror "requires flask-restless to be installed."
- eerror "emerge with USE=-doc followed bu USE=doc"
- die
- fi
- # Changes connect to read issues @ github
- rm -f docs/changelog.rst
- einfo "Generating html docs for ${PN}"
- PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
- || die "Generating html docs for ${PN} failed"
- fi
-}
-
-python_test() {
- nosetests -w tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-restless/flask-restless-0.14.2.ebuild b/dev-python/flask-restless/flask-restless-0.14.2.ebuild
deleted file mode 100644
index 3158a113e74b..000000000000
--- a/dev-python/flask-restless/flask-restless-0.14.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.14.2.ebuild,v 1.1 2015/02/02 05:30:10 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-PYTHON_REQ_USE="sqlite"
-inherit distutils-r1
-
-DESCRIPTION="Flask extension for easy ReSTful API generation"
-HOMEPAGE="http://packages.python.org/Flask-Restless/"
-SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( AGPL-3 BSD )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/mimerender[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
- dev-python/flask-themes[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/mapping.patch )
-
-python_compile_all() {
- if use doc; then
- if ! "${PYTHON}" -c "import flask_restless"; then
- eerror "flask-restless is not installed. Building of the docs"
- eerror "requires flask-restless to be installed."
- eerror "emerge with USE=-doc followed bu USE=doc"
- die
- fi
- # Changes connect to read issues @ github
- rm -f docs/changelog.rst
- einfo "Generating html docs for ${PN}"
- PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
- || die "Generating html docs for ${PN} failed"
- fi
-}
-
-python_test() {
- nosetests -w tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-restless/flask-restless-0.15.1.ebuild b/dev-python/flask-restless/flask-restless-0.15.1.ebuild
deleted file mode 100644
index 1ef42568cbab..000000000000
--- a/dev-python/flask-restless/flask-restless-0.15.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.15.1.ebuild,v 1.1 2015/02/25 06:02:02 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-PYTHON_REQ_USE="sqlite"
-inherit distutils-r1
-
-DESCRIPTION="Flask extension for easy ReSTful API generation"
-HOMEPAGE="http://packages.python.org/Flask-Restless/"
-SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( AGPL-3 BSD )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/mimerender[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
- dev-python/flask-themes[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/mapping.patch )
-
-python_compile_all() {
- if use doc; then
- if ! "${PYTHON}" -c "import flask_restless"; then
- eerror "flask-restless is not installed. Building of the docs"
- eerror "requires flask-restless to be installed."
- eerror "emerge with USE=-doc followed bu USE=doc"
- die
- fi
- # Changes connect to read issues @ github
- rm -f docs/changelog.rst
- einfo "Generating html docs for ${PN}"
- PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
- || die "Generating html docs for ${PN} failed"
- fi
-}
-
-python_test() {
- nosetests -w tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}