summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-10 17:30:41 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-10 17:30:41 +0000
commit51a59f08ce568cd2ffe70a544dba0e97c1c188a5 (patch)
tree09c69bd28b339fc5360babadaf366ed90baaffe7 /dev-python/fonttools
parentremoving old ebuild, fixing subslot deps (diff)
downloadgentoo-2-51a59f08ce568cd2ffe70a544dba0e97c1c188a5.tar.gz
gentoo-2-51a59f08ce568cd2ffe70a544dba0e97c1c188a5.tar.bz2
gentoo-2-51a59f08ce568cd2ffe70a544dba0e97c1c188a5.zip
revbump, migrate -> distutils-r1, rm old
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/ChangeLog10
-rw-r--r--dev-python/fonttools/fonttools-2.3-r1.ebuild28
2 files changed, 35 insertions, 3 deletions
diff --git a/dev-python/fonttools/ChangeLog b/dev-python/fonttools/ChangeLog
index a5ab773e0934..31912d15eaf0 100644
--- a/dev-python/fonttools/ChangeLog
+++ b/dev-python/fonttools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/fonttools
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fonttools/ChangeLog,v 1.28 2012/08/02 22:24:52 neurogeek Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fonttools/ChangeLog,v 1.29 2013/06/10 17:30:41 idella4 Exp $
+
+*fonttools-2.3-r1 (10 Jun 2013)
+
+ 10 Jun 2013; Ian Delaney <idella4@gentoo.org> +fonttools-2.3-r1.ebuild:
+ revbump, migrate -> distutils-r1, rm old
02 Aug 2012; Jesus Rivero <neurogeek@gentoo.org> fonttools-2.3.ebuild:
Bumped to EAPI 4 and added xml(+) to PYTHON_USE_WITH
@@ -110,4 +115,3 @@
+fonttools-2.0_beta1.ebuild:
Initial import. Thanks to Mike C. Fletcher <mcfletch@rogers.com>
and MATSUU Takuto <matsuu@gentoo.org>. This closes bug #54865
-
diff --git a/dev-python/fonttools/fonttools-2.3-r1.ebuild b/dev-python/fonttools/fonttools-2.3-r1.ebuild
new file mode 100644
index 000000000000..824dc2485d5d
--- /dev/null
+++ b/dev-python/fonttools/fonttools-2.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fonttools/fonttools-2.3-r1.ebuild,v 1.1 2013/06/10 17:30:41 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="http://fonttools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/numpy-1.0.2[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.txt Doc/{changes.txt,install.txt} )
+
+python_install_all() {
+ dohtml Doc/documentation.html || die "dohtml failed"
+ distutils-r1_python_install_all
+}