summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-01 01:20:32 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-01 01:20:32 +0000
commit4800b25d6b9292848687c17ebe94771a0f2eea01 (patch)
tree9632d95912c4f97836b67e2c4b0c960bea84c7b0 /dev-python/gdata
parentVersion bump (diff)
downloadgentoo-2-4800b25d6b9292848687c17ebe94771a0f2eea01.tar.gz
gentoo-2-4800b25d6b9292848687c17ebe94771a0f2eea01.tar.bz2
gentoo-2-4800b25d6b9292848687c17ebe94771a0f2eea01.zip
Version bump.
(Portage version: 15502-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gdata')
-rw-r--r--dev-python/gdata/ChangeLog8
-rw-r--r--dev-python/gdata/gdata-2.0.8.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/gdata/ChangeLog b/dev-python/gdata/ChangeLog
index 8becfe5ae1dd..8000602513be 100644
--- a/dev-python/gdata/ChangeLog
+++ b/dev-python/gdata/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gdata
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.52 2010/01/28 18:27:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.53 2010/03/01 01:20:32 arfrever Exp $
+
+*gdata-2.0.8 (01 Mar 2010)
+
+ 01 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +gdata-2.0.8.ebuild:
+ Version bump.
*gdata-2.0.7 (28 Jan 2010)
diff --git a/dev-python/gdata/gdata-2.0.8.ebuild b/dev-python/gdata/gdata-2.0.8.ebuild
new file mode 100644
index 000000000000..e7342ec116dd
--- /dev/null
+++ b/dev-python/gdata/gdata-2.0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-2.0.8.ebuild,v 1.1 2010/03/01 01:20:32 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+MY_P="gdata-${PV}"
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="http://code.google.com/p/gdata-python-client/ http://pypi.python.org/pypi/gdata"
+SRC_URI="http://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DEPEND="|| ( >=dev-lang/python-2.5[xml] dev-python/elementtree )"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="atom gdata"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/run_data_tests.py -v || die "Data tests failed with Python ${PYTHON_ABI}"
+
+ # run_service_tests.py requires interaction (and a valid Google account), so skip it.
+ # PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/run_service_tests.py -v || die "Service tests failed with Python ${PYTHON_ABI}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}