summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-05 23:26:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-05 23:26:25 +0000
commit6786f8218021d94a0f1ec4ad1518b71159c96b74 (patch)
treeb9f4370b09e32727076370954341186a589b1eea /dev-python/gst-python
parentBump (diff)
downloadgentoo-2-6786f8218021d94a0f1ec4ad1518b71159c96b74.tar.gz
gentoo-2-6786f8218021d94a0f1ec4ad1518b71159c96b74.tar.bz2
gentoo-2-6786f8218021d94a0f1ec4ad1518b71159c96b74.zip
Version bump.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/ChangeLog7
-rw-r--r--dev-python/gst-python/gst-python-0.10.13.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/gst-python/ChangeLog b/dev-python/gst-python/ChangeLog
index f5691434f918..7a24cb896cc8 100644
--- a/dev-python/gst-python/ChangeLog
+++ b/dev-python/gst-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gst-python
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.46 2008/11/22 19:39:02 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.47 2008/12/05 23:26:25 ssuominen Exp $
+
+*gst-python-0.10.13 (05 Dec 2008)
+
+ 05 Dec 2008; <ssuominen@gentoo.org> +gst-python-0.10.13.ebuild:
+ Version bump.
22 Nov 2008; Hanno Boeck <hanno@gentoo.org> gst-python-0.10.12.ebuild:
Does not require pygtk, can alternatively use pygobect.
diff --git a/dev-python/gst-python/gst-python-0.10.13.ebuild b/dev-python/gst-python/gst-python-0.10.13.ebuild
new file mode 100644
index 000000000000..6de4e489cba4
--- /dev/null
+++ b/dev-python/gst-python/gst-python-0.10.13.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.13.ebuild,v 1.1 2008/12/05 23:26:25 ssuominen Exp $
+
+NEED_PYTHON=2.4
+
+inherit autotools eutils multilib python
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="|| ( >=dev-python/pygobject-2.11.2 >=dev-python/pygtk-2.6.3 )
+ >=media-libs/gstreamer-0.10.12
+ >=media-libs/gst-plugins-base-0.10.12
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.10.9-lazy.patch
+
+ rm -f py-compile || die "rm failed."
+ ln -s $(type -P true) py-compile || die "ln failed."
+
+ AT_M4DIR="common/m4" eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/pygst.py
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gst-0.10
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}