summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-24 19:45:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-24 19:45:32 +0000
commitaf1c8211404da0886515be28be96a758a075f881 (patch)
tree815988be1fd014ab51d9196a9695f0e384b3fb03 /dev-python/gst-python
parentstable x86, bug 210902 (diff)
downloadgentoo-2-af1c8211404da0886515be28be96a758a075f881.tar.gz
gentoo-2-af1c8211404da0886515be28be96a758a075f881.tar.bz2
gentoo-2-af1c8211404da0886515be28be96a758a075f881.zip
fix python eclass use, bug #207667
add examples USE flag, bug #111508 (Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/ChangeLog7
-rw-r--r--dev-python/gst-python/gst-python-0.10.10.ebuild16
2 files changed, 18 insertions, 5 deletions
diff --git a/dev-python/gst-python/ChangeLog b/dev-python/gst-python/ChangeLog
index c87ef7e896cb..167e8e36485c 100644
--- a/dev-python/gst-python/ChangeLog
+++ b/dev-python/gst-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gst-python
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.36 2008/01/29 23:32:04 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.37 2008/02/24 19:45:32 eva Exp $
+
+ 24 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ gst-python-0.10.10.ebuild:
+ fix python eclass use, bug #207667
+ add examples USE flag, bug #111508
*gst-python-0.10.10 (29 Jan 2008)
diff --git a/dev-python/gst-python/gst-python-0.10.10.ebuild b/dev-python/gst-python/gst-python-0.10.10.ebuild
index a108bb97783c..608453386b5f 100644
--- a/dev-python/gst-python/gst-python-0.10.10.ebuild
+++ b/dev-python/gst-python/gst-python-0.10.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.10.ebuild,v 1.2 2008/01/29 23:39:23 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.10.ebuild,v 1.3 2008/02/24 19:45:32 eva Exp $
NEED_PYTHON=2.4
@@ -13,7 +13,7 @@ SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0.10"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="examples"
RDEPEND=">=dev-python/pygtk-2.6.3
>=dev-libs/glib-2.8
@@ -29,14 +29,22 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-0.10.9-lazy.patch
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
AT_M4DIR="common/m4" eautoreconf
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
dodoc AUTHORS ChangeLog NEWS README TODO
- docinto examples
- dodoc examples/*
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*
+ fi
}
pkg_postinst() {