summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-28 22:47:40 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-28 22:47:40 +0000
commit9baac682c9bf4cc595fe7a31614a02f78eb497da (patch)
tree6f66c787223f190d33141034c32a8099891d0c0d /dev-python/imaging
parentEnable python3, add keywords from dev-python/imaging, apply a few patches. (diff)
downloadgentoo-2-9baac682c9bf4cc595fe7a31614a02f78eb497da.tar.gz
gentoo-2-9baac682c9bf4cc595fe7a31614a02f78eb497da.tar.bz2
gentoo-2-9baac682c9bf4cc595fe7a31614a02f78eb497da.zip
Remove imaging-2.0.0, add blocker for dev-python/pillow.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/imaging')
-rw-r--r--dev-python/imaging/ChangeLog8
-rw-r--r--dev-python/imaging/files/imaging-2.0.0-delete_hardcoded_paths.patch178
-rw-r--r--dev-python/imaging/files/imaging-2.0.0-libm_linking.patch20
-rw-r--r--dev-python/imaging/imaging-1.1.7-r1.ebuild5
-rw-r--r--dev-python/imaging/imaging-1.1.7-r2.ebuild3
-rw-r--r--dev-python/imaging/imaging-1.1.7-r4.ebuild3
-rw-r--r--dev-python/imaging/imaging-2.0.0.ebuild121
7 files changed, 14 insertions, 324 deletions
diff --git a/dev-python/imaging/ChangeLog b/dev-python/imaging/ChangeLog
index c849bb573f33..cbeebc31615b 100644
--- a/dev-python/imaging/ChangeLog
+++ b/dev-python/imaging/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/imaging
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/ChangeLog,v 1.88 2013/05/28 22:34:54 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/ChangeLog,v 1.89 2013/05/28 22:47:40 floppym Exp $
+
+ 28 May 2013; Mike Gilbert <floppym@gentoo.org>
+ -files/imaging-2.0.0-delete_hardcoded_paths.patch,
+ -files/imaging-2.0.0-libm_linking.patch, -imaging-2.0.0.ebuild,
+ imaging-1.1.7-r1.ebuild, imaging-1.1.7-r2.ebuild, imaging-1.1.7-r4.ebuild:
+ Remove imaging-2.0.0, add blocker for dev-python/pillow.
28 May 2013; Mike Gilbert <floppym@gentoo.org> imaging-2.0.0.ebuild:
Depend on unzip.
diff --git a/dev-python/imaging/files/imaging-2.0.0-delete_hardcoded_paths.patch b/dev-python/imaging/files/imaging-2.0.0-delete_hardcoded_paths.patch
deleted file mode 100644
index ed5bdca65cb3..000000000000
--- a/dev-python/imaging/files/imaging-2.0.0-delete_hardcoded_paths.patch
+++ /dev/null
@@ -1,178 +0,0 @@
---- setup.py
-+++ setup.py
-@@ -56,11 +56,6 @@
- return None
-
-
--def _lib_include(root):
-- # map root to (root/lib, root/include)
-- return os.path.join(root, "lib"), os.path.join(root, "include")
--
--
- def _read(file):
- return open(file, 'rb').read()
-
-@@ -105,102 +100,17 @@
- _add_directory(include_dirs, include_root)
-
- #
-- # add platform directories
--
-- if sys.platform == "cygwin":
-- # pythonX.Y.dll.a is in the /usr/lib/pythonX.Y/config directory
-- _add_directory(library_dirs, os.path.join(
-- "/usr/lib", "python%s" % sys.version[:3], "config"))
--
-- elif sys.platform == "darwin":
-- # attempt to make sure we pick freetype2 over other versions
-- _add_directory(include_dirs, "/sw/include/freetype2")
-- _add_directory(include_dirs, "/sw/lib/freetype2/include")
-- # fink installation directories
-- _add_directory(library_dirs, "/sw/lib")
-- _add_directory(include_dirs, "/sw/include")
-- # darwin ports installation directories
-- _add_directory(library_dirs, "/opt/local/lib")
-- _add_directory(include_dirs, "/opt/local/include")
-- # freetype2 ships with X11
-- _add_directory(library_dirs, "/usr/X11/lib")
-- _add_directory(include_dirs, "/usr/X11/include")
--
-- elif sys.platform.startswith("linux"):
-- for platform_ in (platform.processor(),platform.architecture()[0]):
-- if not platform_: continue
--
-- if platform_ in ["x86_64", "64bit"]:
-- _add_directory(library_dirs, "/lib64")
-- _add_directory(library_dirs, "/usr/lib64")
-- _add_directory(library_dirs, "/usr/lib/x86_64-linux-gnu")
-- break
-- elif platform_ in ["i386", "i686", "32bit"]:
-- _add_directory(library_dirs, "/usr/lib/i386-linux-gnu")
-- break
-- else:
-- raise ValueError("Unable to identify Linux platform: `%s`" % platform_)
--
-- # XXX Kludge. Above /\ we brute force support multiarch. Here we
-- # try Barry's more general approach. Afterward, something should
-- # work ;-)
-- self.add_multiarch_paths()
--
-- _add_directory(library_dirs, "/usr/local/lib")
-- # FIXME: check /opt/stuff directories here?
--
-- prefix = sysconfig.get_config_var("prefix")
-- if prefix:
-- _add_directory(library_dirs, os.path.join(prefix, "lib"))
-- _add_directory(include_dirs, os.path.join(prefix, "include"))
--
-- #
- # locate tkinter libraries
-
-
- if _tkinter:
- TCL_VERSION = _tkinter.TCL_VERSION[:3]
-
-- if _tkinter and not TCL_ROOT:
-- # we have Tkinter but the TCL_ROOT variable was not set;
-- # try to locate appropriate Tcl/Tk libraries
-- PYVERSION = sys.version[0] + sys.version[2]
-- TCLVERSION = TCL_VERSION[0] + TCL_VERSION[2]
-- roots = [
-- # common installation directories, mostly for Windows
-- # (for Unix-style platforms, we'll check in well-known
-- # locations later)
-- os.path.join("/py" + PYVERSION, "Tcl"),
-- os.path.join("/python" + PYVERSION, "Tcl"),
-- "/Tcl", "/Tcl" + TCLVERSION, "/Tcl" + TCL_VERSION,
-- os.path.join(os.environ.get("ProgramFiles", ""), "Tcl"),
-- ]
-- for TCL_ROOT in roots:
-- TCL_ROOT = os.path.abspath(TCL_ROOT)
-- if os.path.isfile(os.path.join(TCL_ROOT, "include", "tk.h")):
-- # FIXME: use distutils logging (?)
-- print("--- using Tcl/Tk libraries at", TCL_ROOT)
-- print("--- using Tcl/Tk version", TCL_VERSION)
-- TCL_ROOT = _lib_include(TCL_ROOT)
-- break
-- else:
-- TCL_ROOT = None
--
-
- #
- # add standard directories
-
-- # look for tcl specific subdirectory (e.g debian)
-- if _tkinter:
-- tcl_dir = "/usr/include/tcl" + TCL_VERSION
-- if os.path.isfile(os.path.join(tcl_dir, "tk.h")):
-- _add_directory(include_dirs, tcl_dir)
--
- # standard locations
-- _add_directory(library_dirs, "/usr/local/lib")
-- _add_directory(include_dirs, "/usr/local/include")
--
-- _add_directory(library_dirs, "/usr/lib")
- _add_directory(include_dirs, "/usr/include")
-
- #
-@@ -333,28 +243,7 @@
- "_webp", ["_webp.c"], libraries=["webp"]))
-
-
-- if sys.platform == "darwin":
-- # locate Tcl/Tk frameworks
-- frameworks = []
-- framework_roots = [
-- "/Library/Frameworks",
-- "/System/Library/Frameworks"]
-- for root in framework_roots:
-- if (os.path.exists(os.path.join(root, "Tcl.framework")) and
-- os.path.exists(os.path.join(root, "Tk.framework"))):
-- print("--- using frameworks at %s" % root)
-- frameworks = ["-framework", "Tcl", "-framework", "Tk"]
-- dir = os.path.join(root, "Tcl.framework", "Headers")
-- _add_directory(self.compiler.include_dirs, dir, 0)
-- dir = os.path.join(root, "Tk.framework", "Headers")
-- _add_directory(self.compiler.include_dirs, dir, 1)
-- break
-- if frameworks:
-- exts.append(Extension(
-- "_imagingtk", ["_imagingtk.c", "Tk/tkImaging.c"],
-- extra_compile_args=frameworks, extra_link_args=frameworks))
-- feature.tcl = feature.tk = 1 # mark as present
-- elif feature.tcl and feature.tk:
-+ if feature.tcl and feature.tk:
- exts.append(Extension(
- "_imagingtk", ["_imagingtk.c", "Tk/tkImaging.c"],
- libraries=[feature.tcl, feature.tk]))
-@@ -445,30 +334,6 @@
- if m.group(1) < "1.2.3":
- return m.group(1)
-
-- # http://hg.python.org/users/barry/rev/7e8deab93d5a
-- def add_multiarch_paths(self):
-- # Debian/Ubuntu multiarch support.
-- # https://wiki.ubuntu.com/MultiarchSpec
-- # self.build_temp
-- tmpfile = os.path.join(self.build_temp, 'multiarch')
-- if not os.path.exists(self.build_temp):
-- os.makedirs(self.build_temp)
-- ret = os.system('dpkg-architecture -qDEB_HOST_MULTIARCH > %s' %
-- tmpfile)
-- ret = os.system(
-- 'dpkg-architecture -qDEB_HOST_MULTIARCH > %s 2> /dev/null' %
-- tmpfile)
-- try:
-- if ret >> 8 == 0:
-- fp = open(tmpfile, 'r')
-- multiarch_path_component = fp.readline().strip()
-- _add_directory(self.compiler.library_dirs,
-- '/usr/lib/' + multiarch_path_component)
-- _add_directory(self.compiler.include_dirs,
-- '/usr/include/' + multiarch_path_component)
-- finally:
-- os.unlink(tmpfile)
--
- setup(
- name=NAME,
- version=VERSION,
diff --git a/dev-python/imaging/files/imaging-2.0.0-libm_linking.patch b/dev-python/imaging/files/imaging-2.0.0-libm_linking.patch
deleted file mode 100644
index 35d1df5a406b..000000000000
--- a/dev-python/imaging/files/imaging-2.0.0-libm_linking.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- setup.py
-+++ setup.py
-@@ -197,7 +197,7 @@
- for file in _LIB_IMAGING:
- files.append(os.path.join("libImaging", file + ".c"))
-
-- libs = []
-+ libs = ["m"]
- defs = []
- if feature.jpeg:
- libs.append(feature.jpeg)
-@@ -249,7 +249,7 @@
- libraries=[feature.tcl, feature.tk]))
-
- if os.path.isfile("_imagingmath.c"):
-- exts.append(Extension("_imagingmath", ["_imagingmath.c"]))
-+ exts.append(Extension("_imagingmath", ["_imagingmath.c"], libraries=["m"]))
-
- self.extensions[:] = exts
-
diff --git a/dev-python/imaging/imaging-1.1.7-r1.ebuild b/dev-python/imaging/imaging-1.1.7-r1.ebuild
index ca501974a07f..7bc3951454be 100644
--- a/dev-python/imaging/imaging-1.1.7-r1.ebuild
+++ b/dev-python/imaging/imaging-1.1.7-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.7-r1.ebuild,v 1.12 2012/12/01 02:02:19 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.7-r1.ebuild,v 1.13 2013/05/28 22:47:40 floppym Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -28,6 +28,7 @@ DEPEND="virtual/jpeg
scanner? ( media-gfx/sane-backends )
X? ( x11-misc/xdg-utils )"
RDEPEND="${DEPEND}"
+RDEPEND+=" !dev-python/pillow"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/imaging/imaging-1.1.7-r2.ebuild b/dev-python/imaging/imaging-1.1.7-r2.ebuild
index 51f1afa49e99..d20475dd9ced 100644
--- a/dev-python/imaging/imaging-1.1.7-r2.ebuild
+++ b/dev-python/imaging/imaging-1.1.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.7-r2.ebuild,v 1.4 2013/02/24 12:15:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.7-r2.ebuild,v 1.5 2013/05/28 22:47:40 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
@@ -25,6 +25,7 @@ DEPEND="virtual/jpeg
scanner? ( media-gfx/sane-backends )
X? ( x11-misc/xdg-utils )"
RDEPEND="${DEPEND}"
+RDEPEND+=" !dev-python/pillow"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/imaging/imaging-1.1.7-r4.ebuild b/dev-python/imaging/imaging-1.1.7-r4.ebuild
index c7eaf21fbcd3..97fc718e7579 100644
--- a/dev-python/imaging/imaging-1.1.7-r4.ebuild
+++ b/dev-python/imaging/imaging-1.1.7-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.7-r4.ebuild,v 1.1 2013/05/07 23:27:25 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.7-r4.ebuild,v 1.2 2013/05/28 22:47:40 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
@@ -28,6 +28,7 @@ RDEPEND="
zlib? ( sys-libs/zlib )
!dev-python/pillow"
DEPEND="${RDEPEND}"
+RDEPEND+=" !dev-python/pillow"
# Tests don't handle missing jpeg, tiff & zlib properly.
REQUIRED_USE="test? ( jpeg tiff zlib )"
diff --git a/dev-python/imaging/imaging-2.0.0.ebuild b/dev-python/imaging/imaging-2.0.0.ebuild
deleted file mode 100644
index 77c9edbd9ec4..000000000000
--- a/dev-python/imaging/imaging-2.0.0.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-2.0.0.ebuild,v 1.3 2013/05/28 22:34:54 floppym Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-PYTHON_REQ_USE='tk?'
-
-inherit distutils-r1 eutils
-
-MY_PN=Pillow
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python Imaging Library (fork)"
-HOMEPAGE="https://github.com/python-imaging/Pillow https://pypi.python.org/pypi/Pillow"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="doc examples jpeg lcms scanner test tiff tk truetype webp zlib"
-
-RDEPEND="
- truetype? ( media-libs/freetype:2= )
- jpeg? ( virtual/jpeg )
- lcms? ( media-libs/lcms:0= )
- scanner? ( media-gfx/sane-backends:0= )
- tiff? ( media-libs/tiff:0= )
- webp? ( media-libs/libwebp:0= )
- zlib? ( sys-libs/zlib:0= )"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )"
-
-# Tests don't handle missing jpeg, tiff & zlib properly.
-# https://github.com/python-imaging/Pillow/pull/199
-REQUIRED_USE="test? ( jpeg tiff zlib )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # Tests like to write to cwd.
- # https://github.com/python-imaging/Pillow/pull/200
- use test && DISTUTILS_IN_SOURCE_BUILD=1
-
- distutils-r1_src_prepare
-}
-
-python_prepare_all() {
- # Apply patches before executing sed.
- local patches=(
- "${FILESDIR}/imaging-1.1.7-no-xv.patch"
- "${FILESDIR}/imaging-2.0.0-delete_hardcoded_paths.patch"
- "${FILESDIR}/imaging-2.0.0-libm_linking.patch"
- )
- epatch "${patches[@]}"
-
- # Add shebangs.
- # https://github.com/python-imaging/Pillow/pull/197
- sed -e "1i#!/usr/bin/env python" -i Scripts/*.py || die
-
- # Disable all the stuff we don't want.
- local f
- for f in jpeg lcms tiff tk webp zlib; do
- if ! use ${f}; then
- sed -i -e "s:feature.${f} =:& None #:" setup.py || die
- fi
- done
- if ! use truetype; then
- sed -i -e 's:feature.freetype =:& None #:' setup.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-# XXX: split into two ebuilds?
-wrap_phase() {
- "${@}"
-
- if use scanner; then
- cd Sane || die
- "${@}"
- fi
-}
-
-python_compile() {
- wrap_phase distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
- "${PYTHON}" Tests/run.py --installed || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- python_doheader libImaging/{Imaging.h,ImPlatform.h}
-
- wrap_phase distutils-r1_python_install
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/. )
- use examples && local EXAMPLES=( Scripts/. )
-
- distutils-r1_python_install_all
-
- if use scanner; then
- docinto sane
- dodoc Sane/{CHANGES,README,sanedoc.txt}
- fi
-
- if use examples && use scanner; then
- docinto examples/sane
- doins Sane/demo_*.py
- fi
-}