summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-06-27 17:40:29 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-06-27 17:40:29 +0000
commit3d246ccd4b47b7aa1e516626358e2d50fef8885c (patch)
tree1c3b433995cc3cb17aa95488a0f4891b7ff7b625 /dev-python/keyring
parent--echangelog=n (diff)
downloadgentoo-2-3d246ccd4b47b7aa1e516626358e2d50fef8885c.tar.gz
gentoo-2-3d246ccd4b47b7aa1e516626358e2d50fef8885c.tar.bz2
gentoo-2-3d246ccd4b47b7aa1e516626358e2d50fef8885c.zip
version bump of dev-python/keyring to 1.5
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/ChangeLog7
-rw-r--r--dev-python/keyring/keyring-1.5.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/keyring/ChangeLog b/dev-python/keyring/ChangeLog
index c5d1be9680df..c7a52527d2c4 100644
--- a/dev-python/keyring/ChangeLog
+++ b/dev-python/keyring/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/keyring
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/ChangeLog,v 1.5 2013/01/07 00:03:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/ChangeLog,v 1.6 2013/06/27 17:40:29 prometheanfire Exp $
+
+*keyring-1.5 (27 Jun 2013)
+
+ 27 Jun 2013; Matthew Thode <prometheanfire@gentoo.org> +keyring-1.5.ebuild:
+ version bump of dev-python/keyring to 1.5
07 Jan 2013; Michał Górny <mgorny@gentoo.org> keyring-1.0.ebuild,
metadata.xml:
diff --git a/dev-python/keyring/keyring-1.5.ebuild b/dev-python/keyring/keyring-1.5.ebuild
new file mode 100644
index 000000000000..3c60da5da578
--- /dev/null
+++ b/dev-python/keyring/keyring-1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/keyring-1.5.ebuild,v 1.1 2013/06/27 17:40:29 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} python{3_1,3_2,3_3} pypy{1_9,2_0} )
+#tests restricted due to unpackaged dependancies
+RESTRICT="test"
+
+inherit distutils-r1
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://bitbucket.org/kang/python-keyring-lib"
+SRC_URI="mirror://pypi/k/${PN}/${P}.zip"
+
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+PATCHES=(
+)
+# "${FILESDIR}/setup-1.0.patch"
+
+python_test() {
+ # test_backend.py and test_core.py access keyring backends
+ # which may spawn password prompts and do other damage.
+
+ # XXX: leave out the harmless tests (dummy backends?)
+
+ for t in test_{cli,util}.py; do
+ "${PYTHON}" "${BUILD_DIR}"/lib/${PN}/tests/${t} \
+ || die "${t} fails with ${EPYTHON}"
+ done
+}