summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-02-27 19:00:40 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-02-27 19:00:40 +0000
commit8d645330f6228cf6b80235126a1998063510f70c (patch)
tree8a4cac53d555bdd3247ab3b84d8f47e1aa92e080 /dev-python/lp_solve
parentStable for x86, wrt bug #456822 (diff)
downloadgentoo-2-8d645330f6228cf6b80235126a1998063510f70c.tar.gz
gentoo-2-8d645330f6228cf6b80235126a1998063510f70c.tar.bz2
gentoo-2-8d645330f6228cf6b80235126a1998063510f70c.zip
Switch to python-r1
(Portage version: 2.2.01.21688-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/lp_solve')
-rw-r--r--dev-python/lp_solve/ChangeLog10
-rw-r--r--dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/lp_solve/ChangeLog b/dev-python/lp_solve/ChangeLog
index 67bf6d64457e..f019622ebb84 100644
--- a/dev-python/lp_solve/ChangeLog
+++ b/dev-python/lp_solve/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/lp_solve
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lp_solve/ChangeLog,v 1.3 2012/07/09 17:20:49 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lp_solve/ChangeLog,v 1.4 2013/02/27 19:00:40 bicatali Exp $
+
+*lp_solve-5.5.2.0-r1 (27 Feb 2013)
+
+ 27 Feb 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ +lp_solve-5.5.2.0-r1.ebuild:
+ Switch to python-r1
09 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> lp_solve-5.5.2.0.ebuild:
keyword amd64-linux and x86-linux
diff --git a/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild b/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild
new file mode 100644
index 000000000000..cf7b2c933a6e
--- /dev/null
+++ b/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild,v 1.1 2013/02/27 19:00:40 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python wrappers for lpsolve linear programming library"
+HOMEPAGE="http://lpsolve.sourceforge.net/5.5/Python.htm"
+SRC_URI="mirror://sourceforge/lpsolve/${PN}_${PV}_Python_source.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-mathematics/lpsolve"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}_5.5/extra/Python/"
+
+PATCHES=( "${FILESDIR}"/${P}-setup.patch )
+
+python_test() {
+ PYTHONPATH="$(ls -d ${BUILD_DIR}/lib.*)" "${EPYTHON}" lpdemo.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc changes
+ use doc && dohtml Python.htm
+ insinto /usr/share/doc/${PF}/examples
+ use examples && doins ex*py
+}