summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-10-09 19:07:58 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-10-09 19:07:58 +0000
commitc183cf24aeb6031900fab73d324691e0920aab72 (patch)
tree7cb9186f8f1253cc7c7f43eeda1f1bcf29a8b2e3 /dev-python/matplotlib
parentDelete older ebuilds. (diff)
downloadgentoo-2-c183cf24aeb6031900fab73d324691e0920aab72.tar.gz
gentoo-2-c183cf24aeb6031900fab73d324691e0920aab72.tar.bz2
gentoo-2-c183cf24aeb6031900fab73d324691e0920aab72.zip
Linking CXX with python versioning, fixing bug #287531
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog6
-rw-r--r--dev-python/matplotlib/matplotlib-0.99.0.ebuild180
-rw-r--r--dev-python/matplotlib/matplotlib-0.99.1.1.ebuild5
3 files changed, 8 insertions, 183 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index d37dfe6e6c1f..3828984f6e64 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.71 2009/10/05 21:51:00 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.72 2009/10/09 19:07:58 bicatali Exp $
+
+ 09 Oct 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ -matplotlib-0.99.0.ebuild, matplotlib-0.99.1.1.ebuild:
+ Linking CXX with python versioning, fixing bug #287531
05 Oct 2009; Mounir Lamouri <volkmar@gentoo.org>
matplotlib-0.98.5.3.ebuild, matplotlib-0.99.0.ebuild,
diff --git a/dev-python/matplotlib/matplotlib-0.99.0.ebuild b/dev-python/matplotlib/matplotlib-0.99.0.ebuild
deleted file mode 100644
index aeabf71b8bab..000000000000
--- a/dev-python/matplotlib/matplotlib-0.99.0.ebuild
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.99.0.ebuild,v 1.2 2009/10/05 21:51:00 volkmar Exp $
-
-WX_GTK_VER=2.8
-EAPI=2
-inherit distutils wxwidgets
-
-PDOC="users_guide_${PV}"
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-IUSE="cairo doc excel examples fltk gtk latex qt3 qt4 traits tk wxwidgets"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-LICENSE="PYTHON BSD"
-
-CDEPEND=">=dev-python/numpy-1.1
- dev-python/python-dateutil
- dev-python/pytz
- media-libs/freetype:2
- media-libs/libpng
- gtk? ( dev-python/pygtk )
- tk? ( dev-lang/python[tk] )
- wxwidgets? ( dev-python/wxpython:2.8 )"
-
-DEPEND="${CDEPEND}
- dev-python/pycxx
- dev-util/pkgconfig
- doc? (
- >=dev-python/sphinx-0.5.1
- || (
- >=media-gfx/graphviz-2.24.0[cairo]
- <media-gfx/graphviz-2.24.0[cairo,png]
- )
- || ( ( dev-texlive/texlive-latexextra
- dev-texlive/texlive-latexrecommended )
- ( app-text/ptex dev-tex/latex-unicode ) )
- app-text/dvipng
- dev-python/ipython )"
-
-RDEPEND="${CDEPEND}
- || ( media-fonts/dejavu media-fonts/ttf-bitstream-vera )
- media-fonts/texcm-ttf
- cairo? ( dev-python/pycairo )
- excel? ( dev-python/xlwt )
- fltk? ( dev-python/pyfltk )
- qt3? ( dev-python/PyQt )
- qt4? ( dev-python/PyQt4[X] )
- traits? ( dev-python/traits dev-python/configobj )
- latex? (
- virtual/latex-base
- virtual/ghostscript
- app-text/dvipng
- virtual/poppler-utils
- || ( dev-texlive/texlive-fontsrecommended
- app-text/ptex ) )"
-
-DOCS="INTERACTIVE"
-
-use_setup() {
- local uword="${2}"
- [ -z "${2}" ] && uword="${1}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-src_prepare() {
- # patch from mandriva
- #epatch "${FILESDIR}"/${PN}-0.98.5.2-literal.patch
- # avoid to launch xv while building examples docs
- epatch "${FILESDIR}"/${PN}-0.98.5.2-no-xv.patch
-
- # create setup.cfg (see setup.cfg.template for any changes)
- cat > setup.cfg <<-EOF
- [provide_packages]
- pytz = False
- dateutil = False
- configobj = False
- enthought.traits = False
- [gui_support]
- $(use_setup gtk)
- $(use_setup tk)
- $(use_setup wxwidgets wx)
- $(use_setup qt3 qt)
- $(use_setup qt4)
- $(use_setup fltk)
- $(use_setup cairo)
- EOF
-
- # avoid checks needing a X display
- sed -i \
- -e "s/check_for_gtk()/$(use gtk && echo True || echo False)/" \
- -e "s/check_for_tk()/$(use tk && echo True || echo False)/" \
- setup.py || die "sed setup.py failed"
-
- # respect FHS:
- # - mpl-data in /usr/share/matplotlib
- # - config files in /etc/matplotlib
- sed -i \
- -e "/'mpl-data\/matplotlibrc',/d" \
- -e "/'mpl-data\/matplotlib.conf',/d" \
- -e "s:'lib/matplotlib/mpl-data/matplotlibrc':'matplotlibrc':" \
- -e "s:'lib/matplotlib/mpl-data/matplotlib.conf':'matplotlib.conf':" \
- setup.py \
- || die "sed setup.py for FHS failed"
-
- sed -i \
- -e "s:path = get_data_path():path = '/etc/matplotlib':" \
- -e "s:os.path.dirname(__file__):'/usr/share/${PN}':g" \
- lib/matplotlib/{__init__,config/cutils}.py \
- || die "sed init for FHS failed"
-
- # remove internal copies of fonts, pycxx, pyparsing
- rm -rf \
- CXX \
- lib/matplotlib/mpl-data/fonts/{afm,pdfcorefonts} \
- lib/matplotlib/mpl-data/fonts/ttf/{Vera*,cm*,*.TXT} \
- || die "removed internal copies failed"
- ln -s /usr/share/python*/CXX . || die
-
- # remove pyparsing only when upstream pyparsing included matplotlib
- # fixes. See bug #260025
- #rm -f lib/matplotlib/pyparsing.py
-}
-
-src_compile() {
- unset DISPLAY # bug #278524
- distutils_src_compile
- if use doc; then
- cd "${S}/doc"
- export VARTEXFONTS="${T}"/fonts
- # no die function here: broken compilation at the end, do it twice,
- # result ok.
- MATPLOTLIBDATA="${S}/lib/matplotlib/mpl-data" \
- PYTHONPATH=$(dir -d "${S}"/build/lib*) \
- ${python} make.py html
- MATPLOTLIBDATA="${S}/lib/matplotlib/mpl-data" \
- PYTHONPATH=$(dir -d "${S}"/build/lib*) \
- ${python} make.py
- fi
-}
-
-src_test() {
- einfo "Tests are quite long, be patient"
- cd "${S}/examples/tests"
- PYTHONPATH=$(dir -d "${S}"/build/lib*) ${python} backend_driver.py agg \
- || die "tests failed"
- PYTHONPATH=$(dir -d "${S}"/build/lib*) ${python} backend_driver.py \
- --clean
-}
-
-src_install() {
- distutils_src_install
-
- # respect FHS
- dodir /usr/share/${PN}
- mv "${D}"/usr/*/*/site-packages/${PN}/{mpl-data,backends/Matplotlib.nib} \
- "${D}"/usr/share/${PN} || die "failed renaming"
- insinto /etc/matplotlib
- doins matplotlibrc matplotlib.conf \
- || die "installing config files failed"
-
- # doc and examples
- insinto /usr/share/doc/${PF}
- if use doc; then
- doins doc/build/latex/Matplotlib.pdf || die
- doins -r doc/build/html || die
- fi
- if use examples; then
- doins -r examples || die
- fi
-}
diff --git a/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild b/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild
index af1fd372b9bf..f919cd529f27 100644
--- a/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild,v 1.2 2009/10/05 21:51:00 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild,v 1.3 2009/10/09 19:07:58 bicatali Exp $
WX_GTK_VER=2.8
EAPI=2
@@ -124,7 +124,8 @@ src_prepare() {
lib/matplotlib/mpl-data/fonts/{afm,pdfcorefonts} \
lib/matplotlib/mpl-data/fonts/ttf/{Vera*,cm*,*.TXT} \
|| die "removed internal copies failed"
- ln -s /usr/share/python*/CXX . || die
+ python_version
+ ln -s /usr/share/python${PYVER}/CXX . || die
# remove pyparsing only when upstream pyparsing included matplotlib
# fixes. See bug #260025