summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-24 04:16:31 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-24 04:16:31 +0000
commitdb50ffc5f1497336d53137c7797a6b032c5bd1d9 (patch)
treeb00b918eaa16f5f30345271aff56cf1419538085 /dev-python/nose
parentDelete older ebuilds. (diff)
downloadgentoo-2-db50ffc5f1497336d53137c7797a6b032c5bd1d9.tar.gz
gentoo-2-db50ffc5f1497336d53137c7797a6b032c5bd1d9.tar.bz2
gentoo-2-db50ffc5f1497336d53137c7797a6b032c5bd1d9.zip
Manually call python_generate_wrapper_scripts().
(Portage version: 15134-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/nose-0.11.1.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-python/nose/nose-0.11.1.ebuild b/dev-python/nose/nose-0.11.1.ebuild
index 3fc53195d41b..b612be5bf2df 100644
--- a/dev-python/nose/nose-0.11.1.ebuild
+++ b/dev-python/nose/nose-0.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.11.1.ebuild,v 1.12 2009/11/23 01:43:59 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.11.1.ebuild,v 1.13 2009/12/24 04:16:31 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -8,7 +8,7 @@ SUPPORT_PYTHON_ABIS="1"
inherit distutils eutils
DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/ http://code.google.com/p/python-nose/ http://pypi.python.org/pypi/nose"
+HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/ http://code.google.com/p/python-nose/ http://pypi.python.org/pypi/nose https://bitbucket.org/jpellerin/nose/"
SRC_URI="http://somethingaboutorange.com/mrl/projects/nose/${P}.tar.gz"
LICENSE="LGPL-2.1"
@@ -16,13 +16,14 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
IUSE="doc examples test"
-# dev-python/setuptools is used at run time
RDEPEND="dev-python/setuptools"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-0.6 )
test? ( dev-python/twisted )"
RESTRICT_PYTHON_ABIS="3.*"
+DOCS="AUTHORS"
+
src_prepare() {
distutils_src_prepare
@@ -39,26 +40,25 @@ src_compile() {
if use doc; then
cd doc
mkdir -p .build/html .build/doctrees
- sphinx-build . html || die "building docs failed"
+ sphinx-build . html || die "Generation of documentation failed"
fi
}
src_test() {
- # Create the missing empty directory, that's required for tests to pass
- if [[ ! -e "${S}"/functional_tests/support/empty ]]; then
- mkdir "${S}"/functional_tests/support/empty
- fi
testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py test
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" test
}
python_execute_function testing
}
src_install() {
- DOCS="AUTHORS"
- distutils_src_install --install-data "${EPREFIX}"/usr/share
+ distutils_src_install --install-data "${EPREFIX}/usr/share"
+
+ python_generate_wrapper_scripts -E -f -q "${D}usr/bin/nosetests"
- use doc && dohtml -r -A txt doc/html/*
+ if use doc; then
+ dohtml -r -A txt doc/html/*
+ fi
if use examples; then
insinto /usr/share/doc/${PF}