summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-06-09 16:22:46 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-06-09 16:22:46 +0000
commitf0a541b46824ffb36f032740d696519357c79815 (patch)
treed56395464960aeeadfa6ca86db5428c1ee8baf8e /dev-python/oslo-config
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-f0a541b46824ffb36f032740d696519357c79815.tar.gz
gentoo-2-f0a541b46824ffb36f032740d696519357c79815.tar.bz2
gentoo-2-f0a541b46824ffb36f032740d696519357c79815.zip
bup
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-python/oslo-config')
-rw-r--r--dev-python/oslo-config/ChangeLog8
-rw-r--r--dev-python/oslo-config/oslo-config-1.12.1.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/oslo-config/ChangeLog b/dev-python/oslo-config/ChangeLog
index 6d4e599a57ca..0f0e47295033 100644
--- a/dev-python/oslo-config/ChangeLog
+++ b/dev-python/oslo-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/oslo-config
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/ChangeLog,v 1.25 2015/06/09 15:42:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/ChangeLog,v 1.26 2015/06/09 16:22:46 prometheanfire Exp $
+
+*oslo-config-1.12.1 (09 Jun 2015)
+
+ 09 Jun 2015; Matthew Thode <prometheanfire@gentoo.org>
+ +oslo-config-1.12.1.ebuild:
+ bup
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/dev-python/oslo-config/oslo-config-1.12.1.ebuild b/dev-python/oslo-config/oslo-config-1.12.1.ebuild
new file mode 100644
index 000000000000..c0f9633b2724
--- /dev/null
+++ b/dev-python/oslo-config/oslo-config-1.12.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/oslo-config-1.12.1.ebuild,v 1.1 2015/06/09 16:22:46 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Oslo Configuration API"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.config/oslo.config-${PV}.tar.gz"
+S="${WORKDIR}/oslo.config-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~x86 ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0.0[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/hacking-0.10.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.11[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
+ !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.3.0[${PYTHON_USEDEP}]
+"
+distutils-r1_python_prepare_all() {
+ sed -i '/argparse/d' requirements.txt
+}
+
+python_test() {
+ rm -rf .testrepository || die "could not remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}