summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-03-17 23:19:59 +0000
committerMike Gilbert <floppym@gentoo.org>2013-03-17 23:19:59 +0000
commit41b937d2cf4a479f5a5e285771b9e5a9769bed3e (patch)
treeadc457dd14a05bb93161d2f299bc18bbb303af81 /dev-python/paste/paste-1.7.5.1-r1.ebuild
parentversion bump (diff)
downloadgentoo-2-41b937d2cf4a479f5a5e285771b9e5a9769bed3e.tar.gz
gentoo-2-41b937d2cf4a479f5a5e285771b9e5a9769bed3e.tar.bz2
gentoo-2-41b937d2cf4a479f5a5e285771b9e5a9769bed3e.zip
Actually make things work; docs should only be built with USE=doc, and they are output in BUILD_DIR.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/paste/paste-1.7.5.1-r1.ebuild')
-rw-r--r--dev-python/paste/paste-1.7.5.1-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/paste/paste-1.7.5.1-r1.ebuild b/dev-python/paste/paste-1.7.5.1-r1.ebuild
index f86529ae1693..51dd8f145890 100644
--- a/dev-python/paste/paste-1.7.5.1-r1.ebuild
+++ b/dev-python/paste/paste-1.7.5.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.7.5.1-r1.ebuild,v 1.2 2013/03/15 04:12:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.7.5.1-r1.ebuild,v 1.3 2013/03/17 23:19:59 floppym Exp $
EAPI=5
@@ -48,7 +48,7 @@ python_prepare_all() {
}
python_compile_all() {
- "${PYTHON}" setup.py build || die
+ use doc && esetup.py build_sphinx
}
python_test() {
@@ -56,6 +56,6 @@ python_test() {
}
python_install_all() {
- use doc && local HTML_DOCS=( build/sphinx/html/. )
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
distutils-r1_python_install_all
}