summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-08 05:08:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-08 05:08:54 +0000
commite2f3329c3f34d21de3e30cd6bc097bf5cee4f1e4 (patch)
tree6ba693714c66f8f413259f77ca644f84f3c99890 /dev-python/pastedeploy
parentCleanup old. (diff)
downloadgentoo-2-e2f3329c3f34d21de3e30cd6bc097bf5cee4f1e4.tar.gz
gentoo-2-e2f3329c3f34d21de3e30cd6bc097bf5cee4f1e4.tar.bz2
gentoo-2-e2f3329c3f34d21de3e30cd6bc097bf5cee4f1e4.zip
Bump
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pastedeploy')
-rw-r--r--dev-python/pastedeploy/ChangeLog9
-rw-r--r--dev-python/pastedeploy/pastedeploy-1.5.2.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/pastedeploy/ChangeLog b/dev-python/pastedeploy/ChangeLog
index 88590f0b69de..e93e81a9b693 100644
--- a/dev-python/pastedeploy/ChangeLog
+++ b/dev-python/pastedeploy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pastedeploy
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/ChangeLog,v 1.14 2013/09/05 18:46:58 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/ChangeLog,v 1.15 2014/01/08 05:08:54 patrick Exp $
+
+*pastedeploy-1.5.2 (08 Jan 2014)
+
+ 08 Jan 2014; Patrick Lauer <patrick@gentoo.org> +pastedeploy-1.5.2.ebuild:
+ Bump
05 Sep 2013; Michał Górny <mgorny@gentoo.org> pastedeploy-1.5.0-r1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/pastedeploy/pastedeploy-1.5.2.ebuild b/dev-python/pastedeploy/pastedeploy-1.5.2.ebuild
new file mode 100644
index 000000000000..ef350ab39ad7
--- /dev/null
+++ b/dev-python/pastedeploy/pastedeploy-1.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/pastedeploy-1.5.2.ebuild,v 1.1 2014/01/08 05:08:54 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PN="PasteDeploy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Load, configure, and compose WSGI applications and servers"
+HOMEPAGE="http://pythonpaste.org/deploy/ http://pypi.python.org/pypi/PasteDeploy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use doc && dodoc docs/*.txt
+}