summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-03-14 03:01:48 +0000
committerMike Gilbert <floppym@gentoo.org>2013-03-14 03:01:48 +0000
commit2987ee5e76aba76bfc85d2ab81aee89a6ca69eb4 (patch)
treed7ea862991feb8529bd9a2f826797ba3c4717f97 /dev-python/paver/paver-1.2.0.ebuild
parentMove udev-acl and other binaries out from /usr/libexec and move them over to ... (diff)
downloadgentoo-2-2987ee5e76aba76bfc85d2ab81aee89a6ca69eb4.tar.gz
gentoo-2-2987ee5e76aba76bfc85d2ab81aee89a6ca69eb4.tar.bz2
gentoo-2-2987ee5e76aba76bfc85d2ab81aee89a6ca69eb4.zip
Version bump. Adds python3 support. Resolves bug 461338.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/paver/paver-1.2.0.ebuild')
-rw-r--r--dev-python/paver/paver-1.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/paver/paver-1.2.0.ebuild b/dev-python/paver/paver-1.2.0.ebuild
new file mode 100644
index 000000000000..230220b66173
--- /dev/null
+++ b/dev-python/paver/paver-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paver/paver-1.2.0.ebuild,v 1.1 2013/03/14 03:01:47 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_PN=${PN/p/P}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python-based software project scripting tool along the lines of Make"
+HOMEPAGE="http://www.blueskyonmars.com/projects/paver/ http://pypi.python.org/pypi/Paver"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="README.rst"
+PATCHES=( "${FILESDIR}/${P}-skip-cog-tests.patch" )
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}