summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-07-25 02:22:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-07-25 02:22:14 +0000
commit917527b63969d0f3703109842a11ebed2cae4d52 (patch)
treec2f3eb4de1d93c9107e0077f614ed9d244d5afa6 /dev-python/pep8
parentQA: Restore version needed by other packages (diff)
downloadgentoo-2-917527b63969d0f3703109842a11ebed2cae4d52.tar.gz
gentoo-2-917527b63969d0f3703109842a11ebed2cae4d52.tar.bz2
gentoo-2-917527b63969d0f3703109842a11ebed2cae4d52.zip
QA: Restore another version needed by other packages
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pep8')
-rw-r--r--dev-python/pep8/ChangeLog8
-rw-r--r--dev-python/pep8/pep8-1.2.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/pep8/ChangeLog b/dev-python/pep8/ChangeLog
index 83637f6412c8..efd630e4912e 100644
--- a/dev-python/pep8/ChangeLog
+++ b/dev-python/pep8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pep8
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/ChangeLog,v 1.18 2013/07/25 02:21:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/ChangeLog,v 1.19 2013/07/25 02:22:14 patrick Exp $
+
+*pep8-1.2 (25 Jul 2013)
+
+ 25 Jul 2013; Patrick Lauer <patrick@gentoo.org> +pep8-1.2.ebuild,
+ pep8-1.3.3.ebuild:
+ QA: Restore another version needed by other packages
*pep8-1.3.3 (25 Jul 2013)
diff --git a/dev-python/pep8/pep8-1.2.ebuild b/dev-python/pep8/pep8-1.2.ebuild
new file mode 100644
index 000000000000..699cdb68e2e9
--- /dev/null
+++ b/dev-python/pep8/pep8-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/pep8-1.2.ebuild,v 1.3 2013/07/25 02:22:14 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils vcs-snapshot
+
+DESCRIPTION="Python style guide checker"
+HOMEPAGE="http://github.com/jcrocholl/pep8 http://pypi.python.org/pypi/pep8"
+SRC_URI="https://github.com/jcrocholl/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME=${PN}.py
+DOCS="CHANGES.txt"
+
+src_test() {
+ test_func() {
+ local test_ok=0
+ PYTHONPATH="${S}" "$(PYTHON)" ${PYTHON_MODNAME} -v --testsuite=testsuite || test_ok=1
+ PYTHONPATH="${S}" "$(PYTHON)" ${PYTHON_MODNAME} --doctest -v || test_ok=1
+ return ${test_ok}
+ }
+ python_execute_function test_func
+}