summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-20 07:48:23 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-20 07:48:23 +0000
commit193d433bf11d750614e5e028884e52006d2b4455 (patch)
treec82fbec3b4cd16dc3b32a31fd001c2a2cbbb926d /dev-python/pgmagick
parentHandle IDN dependency for resolved. (diff)
downloadgentoo-2-193d433bf11d750614e5e028884e52006d2b4455.tar.gz
gentoo-2-193d433bf11d750614e5e028884e52006d2b4455.tar.bz2
gentoo-2-193d433bf11d750614e5e028884e52006d2b4455.zip
bump; drop py2.6, add IUSE test, test dep, test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pgmagick')
-rw-r--r--dev-python/pgmagick/ChangeLog7
-rw-r--r--dev-python/pgmagick/pgmagick-0.5.8.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/pgmagick/ChangeLog b/dev-python/pgmagick/ChangeLog
index 495e7cca33ef..3f287b9ed65c 100644
--- a/dev-python/pgmagick/ChangeLog
+++ b/dev-python/pgmagick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pgmagick
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pgmagick/ChangeLog,v 1.4 2014/08/10 21:15:19 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pgmagick/ChangeLog,v 1.5 2014/08/20 07:48:23 idella4 Exp $
+
+*pgmagick-0.5.8 (20 Aug 2014)
+
+ 20 Aug 2014; Ian Delaney <idella4@gentoo.org> +pgmagick-0.5.8.ebuild:
+ bump; drop py2.6, add IUSE test, test dep, test phase
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> pgmagick-0.5.6.ebuild,
pgmagick-0.5.7.ebuild:
diff --git a/dev-python/pgmagick/pgmagick-0.5.8.ebuild b/dev-python/pgmagick/pgmagick-0.5.8.ebuild
new file mode 100644
index 000000000000..6cd68cbe22d8
--- /dev/null
+++ b/dev-python/pgmagick/pgmagick-0.5.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pgmagick/pgmagick-0.5.8.ebuild,v 1.1 2014/08/20 07:48:23 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another boost.python based wrapper for GraphicsMagick"
+HOMEPAGE="https://pypi.python.org/pypi/pgmagick/ http://bitbucket.org/hhatto/pgmagick/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="media-gfx/graphicsmagick[cxx]
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ media-fonts/corefonts )"
+
+python_test() {
+ # https://bitbucket.org/hhatto/pgmagick/issue/46/
+ for test in test/test_*.py; do
+ "${PYTHON}" $test
+ done
+}