summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-05-16 02:21:27 +0000
committerMike Gilbert <floppym@gentoo.org>2014-05-16 02:21:27 +0000
commit2ebcda535b4dcc1e71ffd159cedf65397ef33b02 (patch)
treec0fd6a88ca6e65e1796db94bcd275a0ede787f76 /dev-python/pillow
parentVersion bump with fixes for crashes and UI glitches. Add cinnamon-translation... (diff)
downloadgentoo-2-2ebcda535b4dcc1e71ffd159cedf65397ef33b02.tar.gz
gentoo-2-2ebcda535b4dcc1e71ffd159cedf65397ef33b02.tar.bz2
gentoo-2-2ebcda535b4dcc1e71ffd159cedf65397ef33b02.zip
Remove old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/ChangeLog6
-rw-r--r--dev-python/pillow/pillow-2.0.0-r1.ebuild123
-rw-r--r--dev-python/pillow/pillow-2.3.0.ebuild105
3 files changed, 5 insertions, 229 deletions
diff --git a/dev-python/pillow/ChangeLog b/dev-python/pillow/ChangeLog
index 8cc12cec56aa..02d045857f7f 100644
--- a/dev-python/pillow/ChangeLog
+++ b/dev-python/pillow/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pillow
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pillow/ChangeLog,v 1.32 2014/05/14 16:11:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pillow/ChangeLog,v 1.33 2014/05/16 02:21:27 floppym Exp $
+
+ 16 May 2014; Mike Gilbert <floppym@gentoo.org> -pillow-2.0.0-r1.ebuild,
+ -pillow-2.3.0.ebuild:
+ Remove old.
14 May 2014; Agostino Sarubbo <ago@gentoo.org> pillow-2.4.0.ebuild:
Stable for sparc, wrt bug #507982
diff --git a/dev-python/pillow/pillow-2.0.0-r1.ebuild b/dev-python/pillow/pillow-2.0.0-r1.ebuild
deleted file mode 100644
index 5983765e6c95..000000000000
--- a/dev-python/pillow/pillow-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pillow/pillow-2.0.0-r1.ebuild,v 1.11 2014/01/18 19:51:34 ago Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-PYTHON_REQ_USE='tk?'
-
-inherit distutils-r1 eutils
-
-MY_PN=Pillow
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python Imaging Library (fork)"
-HOMEPAGE="https://github.com/python-imaging/Pillow https://pypi.python.org/pypi/Pillow"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="doc examples jpeg lcms scanner test tiff tk truetype webp zlib"
-
-RDEPEND="
- truetype? ( media-libs/freetype:2= )
- jpeg? ( virtual/jpeg )
- lcms? ( media-libs/lcms:0= )
- scanner? ( media-gfx/sane-backends:0= )
- tiff? ( media-libs/tiff:0= )
- webp? ( media-libs/libwebp:0= )
- zlib? ( sys-libs/zlib:0= )"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )"
-RDEPEND+=" !dev-python/imaging"
-
-# Tests don't handle missing jpeg, tiff & zlib properly.
-# https://github.com/python-imaging/Pillow/pull/199
-REQUIRED_USE="test? ( jpeg tiff zlib )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # Tests like to write to cwd.
- # https://github.com/python-imaging/Pillow/pull/200
- use test && DISTUTILS_IN_SOURCE_BUILD=1
-
- distutils-r1_src_prepare
-}
-
-python_prepare_all() {
- # Apply patches before executing sed.
- local patches=(
- "${FILESDIR}/imaging-1.1.7-no-xv.patch"
- "${FILESDIR}/pillow-2.0.0-delete_hardcoded_paths.patch"
- "${FILESDIR}/pillow-2.0.0-libm_linking.patch"
- "${FILESDIR}/pillow-freetype-2.5.1.patch"
- )
- epatch "${patches[@]}"
-
- # Add shebangs.
- # https://github.com/python-imaging/Pillow/pull/197
- sed -e "1i#!/usr/bin/env python" -i Scripts/*.py || die
-
- # Disable all the stuff we don't want.
- local f
- for f in jpeg lcms tiff tk webp zlib; do
- if ! use ${f}; then
- sed -i -e "s:feature.${f} =:& None #:" setup.py || die
- fi
- done
- if ! use truetype; then
- sed -i -e 's:feature.freetype =:& None #:' setup.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-# XXX: split into two ebuilds?
-wrap_phase() {
- "${@}"
-
- if use scanner; then
- cd Sane || die
- "${@}"
- fi
-}
-
-python_compile() {
- wrap_phase distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
- "${PYTHON}" Tests/run.py --installed || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- python_doheader libImaging/{Imaging.h,ImPlatform.h}
-
- wrap_phase distutils-r1_python_install
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( Scripts/. )
-
- distutils-r1_python_install_all
-
- if use scanner; then
- docinto sane
- dodoc Sane/{CHANGES,README,sanedoc.txt}
- fi
-
- if use examples && use scanner; then
- docinto examples/sane
- dodoc Sane/demo_*.py
- fi
-}
diff --git a/dev-python/pillow/pillow-2.3.0.ebuild b/dev-python/pillow/pillow-2.3.0.ebuild
deleted file mode 100644
index 8312a3d8b47b..000000000000
--- a/dev-python/pillow/pillow-2.3.0.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pillow/pillow-2.3.0.ebuild,v 1.3 2014/01/25 19:18:46 floppym Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-PYTHON_REQ_USE='tk?'
-
-inherit distutils-r1 eutils
-
-MY_PN=Pillow
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python Imaging Library (fork)"
-HOMEPAGE="https://github.com/python-imaging/Pillow https://pypi.python.org/pypi/Pillow"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="doc examples jpeg lcms scanner test tiff tk truetype webp zlib"
-REQUIRED_USE="test? ( jpeg )"
-
-RDEPEND="
- truetype? ( media-libs/freetype:2= )
- jpeg? ( virtual/jpeg )
- lcms? ( media-libs/lcms:0= )
- scanner? ( media-gfx/sane-backends:0= )
- tiff? ( media-libs/tiff:0= )
- webp? ( media-libs/libwebp:0= )
- zlib? ( sys-libs/zlib:0= )"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx
- dev-python/sphinx-better-theme
- )"
-RDEPEND+=" !dev-python/imaging"
-
-S="${WORKDIR}/${MY_P}"
-
-# See _render and _clean in Tests/test_imagefont.py
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # Disable all the stuff we don't want.
- local f
- for f in jpeg lcms tiff tk webp zlib; do
- if ! use ${f}; then
- sed -i -e "s:feature.${f} =:& None #:" setup.py || die
- fi
- done
- if ! use truetype; then
- sed -i -e 's:feature.freetype =:& None #:' setup.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-# XXX: split into two ebuilds?
-wrap_phase() {
- "${@}"
-
- if use scanner; then
- cd Sane || die
- "${@}"
- fi
-}
-
-python_compile() {
- wrap_phase distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" selftest.py --installed || die "Tests fail with ${EPYTHON}"
- "${PYTHON}" Tests/run.py --installed || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- python_doheader libImaging/{Imaging.h,ImPlatform.h}
-
- wrap_phase distutils-r1_python_install
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( Scripts/. )
-
- distutils-r1_python_install_all
-
- if use scanner; then
- docinto sane
- dodoc Sane/{CHANGES,README,sanedoc.txt}
- fi
-
- if use examples && use scanner; then
- docinto examples/sane
- dodoc Sane/demo_*.py
- fi
-}