summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-05-30 10:00:03 +0000
committerTim Harder <radhermit@gentoo.org>2011-05-30 10:00:03 +0000
commit3b44aecdc4ab3ea4553205d25a4ec39f3ef0a46b (patch)
tree39eb102a23843ee53223b45b4201a0e9b9dde524 /dev-python/psutil
parentFix annoying non-compilant virtual mime-types definition. Revision bump with ... (diff)
downloadgentoo-2-3b44aecdc4ab3ea4553205d25a4ec39f3ef0a46b.tar.gz
gentoo-2-3b44aecdc4ab3ea4553205d25a4ec39f3ef0a46b.tar.bz2
gentoo-2-3b44aecdc4ab3ea4553205d25a4ec39f3ef0a46b.zip
Initial import from sunrise thanks to Michał Górny (bug #322977).
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/ChangeLog10
-rw-r--r--dev-python/psutil/metadata.xml5
-rw-r--r--dev-python/psutil/psutil-0.2.1.ebuild31
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/psutil/ChangeLog b/dev-python/psutil/ChangeLog
new file mode 100644
index 000000000000..633573f33e4b
--- /dev/null
+++ b/dev-python/psutil/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/psutil
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/ChangeLog,v 1.1 2011/05/30 10:00:03 radhermit Exp $
+
+*psutil-0.2.1 (30 May 2011)
+
+ 30 May 2011; Tim Harder <radhermit@gentoo.org> +psutil-0.2.1.ebuild,
+ +metadata.xml:
+ Initial import from sunrise thanks to Michał Górny (bug #322977).
+
diff --git a/dev-python/psutil/metadata.xml b/dev-python/psutil/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/psutil/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/psutil/psutil-0.2.1.ebuild b/dev-python/psutil/psutil-0.2.1.ebuild
new file mode 100644
index 000000000000..b1459ba82955
--- /dev/null
+++ b/dev-python/psutil/psutil-0.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/psutil-0.2.1.ebuild,v 1.1 2011/05/30 10:00:03 radhermit Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="http://code.google.com/p/psutil/"
+SRC_URI="http://psutil.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# A few tests are broken
+RESTRICT="test"
+
+src_test() {
+ testing() {
+ # Test suite broken with Python 3
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" test/test_psutil.py
+ }
+ python_execute_function testing
+}