summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-08-06 05:21:53 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-08-06 05:21:53 +0000
commit578255ea23441669db7c8d8f61bab375129afb36 (patch)
tree68ace957575fb000c5daa3a24933807189eacda3 /dev-python/psycopg/psycopg-1.1.21.ebuild
parentAdded PYTHON_MODNAME to pmw-1.2. Added pmw-1.3.2.ebuild. Fixes bug #233638. T... (diff)
downloadgentoo-2-578255ea23441669db7c8d8f61bab375129afb36.tar.gz
gentoo-2-578255ea23441669db7c8d8f61bab375129afb36.tar.bz2
gentoo-2-578255ea23441669db7c8d8f61bab375129afb36.zip
Removed old version. Fixed 1.1.21 to use $(python_get_dir) (See bug #232575). Thanks to Necoro <gentoo@necoro.eu>
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/psycopg/psycopg-1.1.21.ebuild')
-rw-r--r--dev-python/psycopg/psycopg-1.1.21.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/psycopg/psycopg-1.1.21.ebuild b/dev-python/psycopg/psycopg-1.1.21.ebuild
index c73f496aaef5..271d50ed2e25 100644
--- a/dev-python/psycopg/psycopg-1.1.21.ebuild
+++ b/dev-python/psycopg/psycopg-1.1.21.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-1.1.21.ebuild,v 1.13 2008/05/26 12:51:17 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-1.1.21.ebuild,v 1.14 2008/08/06 05:21:53 neurogeek Exp $
inherit python
DESCRIPTION="PostgreSQL database adapter for Python" # best one
-SRC_URI="http://initd.org/pub/software/psycopg/${P}.tar.gz"
+SRC_URI="http://initd.org/pub/software/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.initd.org/software/psycopg"
DEPEND="virtual/python
@@ -28,7 +28,7 @@ src_unpack() {
src_compile() {
python_version
econf \
- --with-mxdatetime-includes=/usr/lib/python${PYVER}/site-packages/mx/DateTime/mxDateTime \
+ --with-mxdatetime-includes=$(python_get_sitedir)/mx/DateTime/mxDateTime \
--with-postgres-includes=/usr/include/postgresql/server \
|| die "./configure failed"
emake || die