summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-11-06 01:32:06 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-11-06 01:32:06 +0000
commit733090e587154e12f3d27d4894d8a4a6f9546a64 (patch)
tree3dac0f5d9c3b3f01d65eaef835882cb9cbbf927b /dev-python/psycopg/psycopg-1.1.21.ebuild
parentFix typo in ChangeLog. (diff)
downloadgentoo-2-733090e587154e12f3d27d4894d8a4a6f9546a64.tar.gz
gentoo-2-733090e587154e12f3d27d4894d8a4a6f9546a64.tar.bz2
gentoo-2-733090e587154e12f3d27d4894d8a4a6f9546a64.zip
version bump stable version, and introduce development version that is hard masked
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-python/psycopg/psycopg-1.1.21.ebuild')
-rw-r--r--dev-python/psycopg/psycopg-1.1.21.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/psycopg/psycopg-1.1.21.ebuild b/dev-python/psycopg/psycopg-1.1.21.ebuild
new file mode 100644
index 000000000000..2f10912d5d31
--- /dev/null
+++ b/dev-python/psycopg/psycopg-1.1.21.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-1.1.21.ebuild,v 1.1 2005/11/06 01:32:06 liquidx Exp $
+
+inherit python
+
+DESCRIPTION="PostgreSQL database adapter for the Python" # best one
+SRC_URI="http://initd.org/pub/software/psycopg/${P}.tar.gz"
+HOMEPAGE="http://www.initd.org/software/psycopg"
+
+DEPEND="virtual/python
+ >=dev-python/egenix-mx-base-2.0.3
+ >=dev-db/postgresql-7.1.3"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE=""
+
+src_compile() {
+ python_version
+ econf \
+ --with-mxdatetime-includes=/usr/lib/python${PYVER}/site-packages/mx/DateTime/mxDateTime \
+ --with-postgres-includes=/usr/include/postgresql/server \
+ || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ cd ${S}
+ sed -e 's:\(echo " install -m 555 $$mod \)\($(PY_MOD_DIR)\)\("; \\\):\1${D}\2/$$mod\3:' \
+ -e 's:\($(INSTALL) -m 555 $$mod \)\($(PY_MOD_DIR)\)\(; \\\):\1${D}\2/$$mod\3:' \
+ -i Makefile
+ make install || die
+
+ dodoc AUTHORS ChangeLog COPYING CREDITS INSTALL README NEWS RELEASE-1.0 SUCCESS TODO
+ docinto doc
+ dodoc doc/*
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/examples/*
+}