summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-23 21:23:45 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-23 21:23:45 +0000
commitdc0ec155366d838816c36a7d72dd22b20b884ad7 (patch)
tree7912e3e3865bf7835c040a82e1d4101117710937 /dev-python/psycopg/psycopg-1.1.21.ebuild
parentStable for HPPA (bug #297672). (diff)
downloadgentoo-2-dc0ec155366d838816c36a7d72dd22b20b884ad7.tar.gz
gentoo-2-dc0ec155366d838816c36a7d72dd22b20b884ad7.tar.bz2
gentoo-2-dc0ec155366d838816c36a7d72dd22b20b884ad7.zip
Fix building (bug #284029).
(Portage version: 15134-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/psycopg/psycopg-1.1.21.ebuild')
-rw-r--r--dev-python/psycopg/psycopg-1.1.21.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/dev-python/psycopg/psycopg-1.1.21.ebuild b/dev-python/psycopg/psycopg-1.1.21.ebuild
index 271d50ed2e25..932a92275481 100644
--- a/dev-python/psycopg/psycopg-1.1.21.ebuild
+++ b/dev-python/psycopg/psycopg-1.1.21.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-1.1.21.ebuild,v 1.14 2008/08/06 05:21:53 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-1.1.21.ebuild,v 1.15 2009/12/23 21:23:45 arfrever Exp $
+
+EAPI="2"
inherit python
@@ -8,37 +10,31 @@ DESCRIPTION="PostgreSQL database adapter for Python" # best one
SRC_URI="http://initd.org/pub/software/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.initd.org/software/psycopg"
-DEPEND="virtual/python
- >=dev-python/egenix-mx-base-2.0.3
- >=virtual/postgresql-base-7.1.3"
-
SLOT="0"
KEYWORDS="alpha ~amd64 ia64 ppc ppc64 sparc x86"
LICENSE="GPL-2"
IUSE=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
+DEPEND=">=dev-python/egenix-mx-base-2.0.3
+ >=virtual/postgresql-base-7.1.3"
+RDEPEND="${DEPEND}"
+src_prepare() {
# fix for bug #134873
sed -e '1245s/static //' -i cursor.c
}
-src_compile() {
- python_version
+src_configure() {
econf \
- --with-mxdatetime-includes=$(python_get_sitedir)/mx/DateTime/mxDateTime \
- --with-postgres-includes=/usr/include/postgresql/server \
- || die "./configure failed"
- emake || die
+ --with-mxdatetime-includes="$(python_get_includedir)/mx" \
+ --with-postgres-includes="/usr/include/postgresql/server"
}
src_install () {
sed -e 's:\(echo " install -m 555 $$mod \)\($(PY_MOD_DIR)\)\("; \\\):\1${D}\2/$$mod\3:' \
-e 's:\($(INSTALL) -m 555 $$mod \)\($(PY_MOD_DIR)\)\(; \\\):\1${D}\2/$$mod\3:' \
-i Makefile
- make install || die
+ emake install || die "emake install failed"
dodoc AUTHORS ChangeLog CREDITS README NEWS RELEASE-1.0 SUCCESS TODO
docinto doc