summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-10 09:56:38 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-10 09:56:38 +0000
commit19343377c0977f16bf2f9b41748b26406726212a (patch)
tree02a1b7463bf4abea533b48a654669a60222cd7db /dev-python/pyatspi
parentRemove restriction on multiple python3s, since pycairo does support multiple ... (diff)
downloadgentoo-2-19343377c0977f16bf2f9b41748b26406726212a.tar.gz
gentoo-2-19343377c0977f16bf2f9b41748b26406726212a.tar.bz2
gentoo-2-19343377c0977f16bf2f9b41748b26406726212a.zip
Update to python-r1.eclass.
(Portage version: 2.2.0_alpha145/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/ChangeLog8
-rw-r--r--dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch26
-rw-r--r--dev-python/pyatspi/pyatspi-2.6.0-r1.ebuild65
3 files changed, 98 insertions, 1 deletions
diff --git a/dev-python/pyatspi/ChangeLog b/dev-python/pyatspi/ChangeLog
index e11841872498..254aa9008446 100644
--- a/dev-python/pyatspi/ChangeLog
+++ b/dev-python/pyatspi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyatspi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/ChangeLog,v 1.16 2012/11/16 13:25:42 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/ChangeLog,v 1.17 2012/12/10 09:56:38 tetromino Exp $
+
+*pyatspi-2.6.0-r1 (10 Dec 2012)
+
+ 10 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +pyatspi-2.6.0-r1.ebuild, +files/pyatspi-2.6.0-examples-python3.patch:
+ Update to python-r1.eclass.
16 Nov 2012; Anthony G. Basile <blueness@gentoo.org> pyatspi-2.6.0.ebuild:
keyword ~ppc ~ppc64, bug #411761
diff --git a/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch b/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch
new file mode 100644
index 000000000000..423cd644073c
--- /dev/null
+++ b/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch
@@ -0,0 +1,26 @@
+From 4f10a696002179082e41568b5109400ac8478a96 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 10 Dec 2012 04:52:03 -0500
+Subject: [PATCH] examples: support python2 and python3 syntax
+
+https://bugzilla.gnome.org/show_bug.cgi?id=689957
+---
+ examples/magFocusTracker.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/examples/magFocusTracker.py b/examples/magFocusTracker.py
+index 47efe00..7ca3b67 100755
+--- a/examples/magFocusTracker.py
++++ b/examples/magFocusTracker.py
+@@ -282,7 +282,7 @@ def main():
+ startTracking()
+ pyatspi.Registry.start()
+ else:
+- print 'Magnification service not available. Exiting.'
++ print('Magnification service not available. Exiting.')
+
+ return 0
+
+--
+1.8.0
+
diff --git a/dev-python/pyatspi/pyatspi-2.6.0-r1.ebuild b/dev-python/pyatspi/pyatspi-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..78e2ebbc949c
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.6.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/pyatspi-2.6.0-r1.ebuild,v 1.1 2012/12/10 09:56:38 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit eutils gnome2 python-r1
+
+DESCRIPTION="Python binding to at-spi library"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="" # test
+
+# test suite is obsolete (at-spi-1.x era) and unpassable
+RESTRICT="test"
+
+COMMON_DEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-${PV}[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=689957
+ epatch "${FILESDIR}/${PN}-2.6.0-examples-python3.patch"
+
+ gnome2_src_prepare
+
+ python_copy_sources
+}
+
+src_configure() {
+ G2CONF="${G2CONF} --disable-tests"
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_doscript examples/magFocusTracker.py
+ }
+ python_foreach_impl run_in_build_dir installing
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "$@"
+ popd > /dev/null
+}