summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-02 23:49:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-02 23:49:24 +0000
commit6e329222d252946c512668653021a44caa3e8699 (patch)
tree0743b33de6d430916e41092a92e67a4a37ba1dbd /dev-python/pycairo
parentAdd live ebuild from keenblade for bug #296484. (diff)
downloadgentoo-2-6e329222d252946c512668653021a44caa3e8699.tar.gz
gentoo-2-6e329222d252946c512668653021a44caa3e8699.tar.bz2
gentoo-2-6e329222d252946c512668653021a44caa3e8699.zip
Fix tests (bug #326635).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/ChangeLog6
-rw-r--r--dev-python/pycairo/pycairo-1.8.10.ebuild25
2 files changed, 24 insertions, 7 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index d31f878c2538..bfdd768e1bcc 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pycairo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.85 2010/06/18 17:53:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.86 2010/07/02 23:49:24 arfrever Exp $
+
+ 02 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pycairo-1.8.10.ebuild:
+ Fix tests (bug #326635).
*pycairo-1.8.10 (18 Jun 2010)
diff --git a/dev-python/pycairo/pycairo-1.8.10.ebuild b/dev-python/pycairo/pycairo-1.8.10.ebuild
index 5b5615e48894..1ebedf1068f9 100644
--- a/dev-python/pycairo/pycairo-1.8.10.ebuild
+++ b/dev-python/pycairo/pycairo-1.8.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.10.ebuild,v 1.1 2010/06/18 17:53:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.10.ebuild,v 1.2 2010/07/02 23:49:24 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -34,24 +34,37 @@ src_prepare() {
}
src_configure() {
- if use doc; then
- econf
- fi
-
if ! use svg; then
export PYCAIRO_DISABLE_SVG="1"
fi
}
+distutils_src_compile_post_hook() {
+ cp src/__init__.py "$(ls -d build-${PYTHON_ABI}/lib.*/cairo)" || die "Copying of src/__init__.py failed"
+}
+
src_compile() {
append-flags -fno-strict-aliasing
distutils_src_compile
if use doc; then
- emake html || die "emake html failed"
+ einfo "Generation of documentation"
+ pushd doc > /dev/null
+ sphinx-build -b html -d .build/doctrees . .build/html || die "Generation of documentation failed"
+ popd > /dev/null
fi
}
+src_test() {
+ # python_execute_py.test -P '$(ls -d build-${PYTHON_ABI}/lib.*):../../$(ls -d build-${PYTHON_ABI}/lib.*)'
+
+ testing() {
+ echo PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*):../../$(ls -d build-${PYTHON_ABI}/lib.*)" py.test
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*):../../$(ls -d build-${PYTHON_ABI}/lib.*)" py.test
+ }
+ python_execute_function testing
+}
+
src_install() {
PKGCONFIG_DIR="${EPREFIX}/usr/$(get_libdir)/pkgconfig" distutils_src_install