summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-16 05:09:23 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-16 05:09:23 +0000
commitfe772bc2e7f727f06d6a7aac913fbda471d9e24a (patch)
treeead209c8de90d1e5a433ea522845e129b6863b4c /dev-python/pycairo
parentUpdated with test and QA fixes, closes bug 283747. (diff)
downloadgentoo-2-fe772bc2e7f727f06d6a7aac913fbda471d9e24a.tar.gz
gentoo-2-fe772bc2e7f727f06d6a7aac913fbda471d9e24a.tar.bz2
gentoo-2-fe772bc2e7f727f06d6a7aac913fbda471d9e24a.zip
Install pycairo.pc in correct directory (bug #283360).
(Portage version: 14274-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/ChangeLog6
-rw-r--r--dev-python/pycairo/files/pycairo-1.8.8-pkgconfig_dir.patch17
-rw-r--r--dev-python/pycairo/pycairo-1.8.8.ebuild8
3 files changed, 27 insertions, 4 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index 2b95e6d66d03..d47cc6a400ab 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pycairo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.73 2009/09/14 02:21:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.74 2009/09/16 05:09:23 arfrever Exp $
+
+ 16 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pycairo-1.8.8.ebuild, +files/pycairo-1.8.8-pkgconfig_dir.patch:
+ Install pycairo.pc in correct directory (bug #283360).
14 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pycairo-1.8.8.ebuild:
diff --git a/dev-python/pycairo/files/pycairo-1.8.8-pkgconfig_dir.patch b/dev-python/pycairo/files/pycairo-1.8.8-pkgconfig_dir.patch
new file mode 100644
index 000000000000..27c24a89402e
--- /dev/null
+++ b/dev-python/pycairo/files/pycairo-1.8.8-pkgconfig_dir.patch
@@ -0,0 +1,17 @@
+--- setup.py
++++ setup.py
+@@ -4,6 +4,7 @@
+ import distutils.dir_util as dut
+ import distutils.file_util as fut
+ import io
++import os
+ import subprocess
+ import sys
+
+@@ -106,5 +107,5 @@
+ description = "python interface for cairo",
+ ext_modules = [cairo],
+ data_files=[('include/pycairo',['src/pycairo.h']),
+- ('lib/pkgconfig',[pkgconfig_file])],
++ (os.environ.get('PKGCONFIG_DIR', 'lib/pkgconfig'),[pkgconfig_file])],
+ )
diff --git a/dev-python/pycairo/pycairo-1.8.8.ebuild b/dev-python/pycairo/pycairo-1.8.8.ebuild
index 7416893ac0d2..0d0d3f46ea11 100644
--- a/dev-python/pycairo/pycairo-1.8.8.ebuild
+++ b/dev-python/pycairo/pycairo-1.8.8.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.8.ebuild,v 1.3 2009/09/14 02:21:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.8.ebuild,v 1.4 2009/09/16 05:09:23 arfrever Exp $
EAPI="2"
NEED_PYTHON="2.6"
SUPPORT_PYTHON_ABIS="1"
-inherit distutils
+inherit distutils multilib
DESCRIPTION="Python wrapper for cairo vector graphics library"
HOMEPAGE="http://cairographics.org/pycairo/"
@@ -33,6 +33,8 @@ src_prepare() {
sed -i \
-e '/if test -n "$$dlist"; then/,/else :; fi/d' \
src/Makefile.in || die "sed in src/Makefile.in failed"
+
+ epatch "${FILESDIR}/${P}-pkgconfig_dir.patch"
}
src_configure() {
@@ -59,7 +61,7 @@ src_test() {
}
src_install() {
- distutils_src_install
+ PKGCONFIG_DIR="/usr/$(get_libdir)/pkgconfig" distutils_src_install
if use doc; then
dohtml -r doc/.build/html/ || die "dohtml -r doc/.build/html/ failed"