summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-25 05:06:38 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-25 05:06:38 +0000
commita3e001e3aecf015d0122d562811b41b3f2fbb118 (patch)
treec251b9a152aff1625901d18b6e38ba400c9c3ca4 /dev-python/pycountry
parentVersion bump. (diff)
downloadgentoo-2-a3e001e3aecf015d0122d562811b41b3f2fbb118.tar.gz
gentoo-2-a3e001e3aecf015d0122d562811b41b3f2fbb118.tar.bz2
gentoo-2-a3e001e3aecf015d0122d562811b41b3f2fbb118.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pycountry')
-rw-r--r--dev-python/pycountry/ChangeLog7
-rw-r--r--dev-python/pycountry/pycountry-1.5.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/pycountry/ChangeLog b/dev-python/pycountry/ChangeLog
index ee8f7f238f49..49e250311373 100644
--- a/dev-python/pycountry/ChangeLog
+++ b/dev-python/pycountry/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycountry
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycountry/ChangeLog,v 1.26 2014/03/01 04:29:11 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycountry/ChangeLog,v 1.27 2014/04/25 05:06:38 radhermit Exp $
+
+*pycountry-1.5 (25 Apr 2014)
+
+ 25 Apr 2014; Tim Harder <radhermit@gentoo.org> +pycountry-1.5.ebuild:
+ Version bump.
01 Mar 2014; Tim Harder <radhermit@gentoo.org> -pycountry-0.14.7-r1.ebuild,
-pycountry-0.14.8.ebuild, -pycountry-0.15.ebuild, -pycountry-0.16.ebuild,
diff --git a/dev-python/pycountry/pycountry-1.5.ebuild b/dev-python/pycountry/pycountry-1.5.ebuild
new file mode 100644
index 000000000000..10e83603ae32
--- /dev/null
+++ b/dev-python/pycountry/pycountry-1.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycountry/pycountry-1.5.ebuild,v 1.1 2014/04/25 05:06:38 radhermit Exp $
+
+EAPI=5
+# pypy pending actioning of bug filed upstream
+PYTHON_COMPAT=( python{2_6,2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO country, subdivision, language, currency and script definitions and their translations"
+HOMEPAGE="http://pypi.python.org/pypi/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( HISTORY.txt README TODO.txt )
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ py.test ${PN}/tests/test_general.py || die
+}