summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-08 19:33:42 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-08 19:33:42 +0000
commitaf0c1577814c6ef312c3adade92a891813d64eda (patch)
tree6dcd8d603256e7ec06c353d717e90605bd5775bc /dev-python/pycparser
parentDev channel bump. Use system snappy. Remove old. (diff)
downloadgentoo-2-af0c1577814c6ef312c3adade92a891813d64eda.tar.gz
gentoo-2-af0c1577814c6ef312c3adade92a891813d64eda.tar.bz2
gentoo-2-af0c1577814c6ef312c3adade92a891813d64eda.zip
Pregenerate lexer and parser tables.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/ChangeLog8
-rw-r--r--dev-python/pycparser/pycparser-2.09.1-r1.ebuild (renamed from dev-python/pycparser/pycparser-2.09.1.ebuild)8
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-python/pycparser/ChangeLog b/dev-python/pycparser/ChangeLog
index a1d0ec15153a..5f2abc14e5b6 100644
--- a/dev-python/pycparser/ChangeLog
+++ b/dev-python/pycparser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pycparser
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycparser/ChangeLog,v 1.5 2013/05/08 15:22:11 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycparser/ChangeLog,v 1.6 2013/05/08 19:33:42 floppym Exp $
+
+*pycparser-2.09.1-r1 (08 May 2013)
+
+ 08 May 2013; Mike Gilbert <floppym@gentoo.org> +pycparser-2.09.1-r1.ebuild,
+ -pycparser-2.09.1.ebuild:
+ Pregenerate lexer and parser tables.
08 May 2013; Ian Delaney <idella4@gentoo.org> pycparser-2.09.1.ebuild:
Add py3.3 support
diff --git a/dev-python/pycparser/pycparser-2.09.1.ebuild b/dev-python/pycparser/pycparser-2.09.1-r1.ebuild
index 1967ecc9f4fc..cbdddac7eb4e 100644
--- a/dev-python/pycparser/pycparser-2.09.1.ebuild
+++ b/dev-python/pycparser/pycparser-2.09.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycparser/pycparser-2.09.1.ebuild,v 1.3 2013/05/08 15:22:11 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycparser/pycparser-2.09.1-r1.ebuild,v 1.1 2013/05/08 19:33:42 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy{1_9,2_0} )
@@ -20,6 +20,12 @@ RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+python_compile() {
+ distutils-r1_python_compile
+ cd "${BUILD_DIR}/lib/pycparser" || die
+ "${PYTHON}" _build_tables.py || die
+}
+
python_test() {
nosetests || die
}