summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-09 13:56:40 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-09 13:56:40 +0000
commit58a19f194ec3365a05942733bf0e4ea5b962c5c3 (patch)
tree1b3cb017f88460ce82ef36b87eff88a7664e5cc4 /dev-python/pycxx
parentDelete older ebuild. (diff)
downloadgentoo-2-58a19f194ec3365a05942733bf0e4ea5b962c5c3.tar.gz
gentoo-2-58a19f194ec3365a05942733bf0e4ea5b962c5c3.tar.bz2
gentoo-2-58a19f194ec3365a05942733bf0e4ea5b962c5c3.zip
Install all required files (bug #358027).
(Portage version: 2.2.0_alpha26_p10/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/ChangeLog9
-rw-r--r--dev-python/pycxx/files/pycxx-6.2.3-installation.patch14
-rw-r--r--dev-python/pycxx/pycxx-6.2.3-r1.ebuild43
3 files changed, 61 insertions, 5 deletions
diff --git a/dev-python/pycxx/ChangeLog b/dev-python/pycxx/ChangeLog
index 621d13374e15..f86e21ebfc1d 100644
--- a/dev-python/pycxx/ChangeLog
+++ b/dev-python/pycxx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pycxx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.25 2011/03/07 23:00:39 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.26 2011/03/09 13:56:40 arfrever Exp $
+
+*pycxx-6.2.3-r1 (09 Mar 2011)
+
+ 09 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pycxx-6.2.3.ebuild, +pycxx-6.2.3-r1.ebuild,
+ files/pycxx-6.2.3-installation.patch:
+ Install all required files (bug #358027).
*pycxx-6.2.3 (07 Mar 2011)
diff --git a/dev-python/pycxx/files/pycxx-6.2.3-installation.patch b/dev-python/pycxx/files/pycxx-6.2.3-installation.patch
index cd7523ccdecd..5f6bfa74f4be 100644
--- a/dev-python/pycxx/files/pycxx-6.2.3-installation.patch
+++ b/dev-python/pycxx/files/pycxx-6.2.3-installation.patch
@@ -1,6 +1,6 @@
--- setup.py
+++ setup.py
-@@ -3,10 +3,12 @@
+@@ -3,10 +3,18 @@
from distutils.command.install import install
from distutils.core import setup
@@ -9,11 +9,17 @@
-sources = (glob( os.path.join( "Src", "*.cxx" ) )
- +glob( os.path.join( "Src", "*.c" ) ))
+headers = (glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.hxx" ) )
-+ +glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.h" ) )
-+ +[os.path.join( "CXX", "Version.hxx" )]
-+ +[os.path.join( "CXX", "WrapPython.h" )])
++ +glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.h" ) ))
++headers += [header for header in
++ glob( os.path.join( "CXX", "*.hxx" ) ) +
++ glob( os.path.join( "CXX", "*.h" ) )
++ if os.path.sep.join((os.path.split(header)[0], "Python%s" % sys.version_info[0], os.path.split(header)[1])) not in headers]
+sources = (glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.cxx" ) )
+ +glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.c" ) ))
++sources += [source for source in
++ glob( os.path.join( "Src", "*.cxx" ) ) +
++ glob( os.path.join( "Src", "*.c" ) )
++ if os.path.sep.join((os.path.split(source)[0], "Python%s" % sys.version_info[0], os.path.split(source)[1])) not in sources]
class my_install (install):
diff --git a/dev-python/pycxx/pycxx-6.2.3-r1.ebuild b/dev-python/pycxx/pycxx-6.2.3-r1.ebuild
new file mode 100644
index 000000000000..eed07172336c
--- /dev/null
+++ b/dev-python/pycxx/pycxx-6.2.3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.3-r1.ebuild,v 1.1 2011/03/09 13:56:40 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit eutils distutils
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+PYTHON_MODNAME="CXX"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-3.patch"
+ epatch "${FILESDIR}/${P}-installation.patch"
+ epatch "${FILESDIR}/${PN}-6.1.0-C_compatible_headers.patch"
+
+ sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r Doc/ || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples/python-2
+ dodoc Demo/Python2/* || die "dodoc failed"
+ docinto examples/python-3
+ dodoc Demo/Python3/* || die "dodoc failed"
+ fi
+}