summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-18 12:35:41 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-18 12:35:41 +0000
commitf04f2d41fba183a1482342045fefcfabcbb53d0f (patch)
tree7f4cccc64c8f92d6a2f87e5f36b9f0ecb40d8587 /dev-python/pyglet
parentnew ebuild for ardour-3.0 and slotmove as well as an icon correction for ardo... (diff)
downloadgentoo-2-f04f2d41fba183a1482342045fefcfabcbb53d0f.tar.gz
gentoo-2-f04f2d41fba183a1482342045fefcfabcbb53d0f.tar.bz2
gentoo-2-f04f2d41fba183a1482342045fefcfabcbb53d0f.zip
dev-python/pyglet: Bump to new python eclasses
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'dev-python/pyglet')
-rw-r--r--dev-python/pyglet/ChangeLog10
-rw-r--r--dev-python/pyglet/metadata.xml22
-rw-r--r--dev-python/pyglet/pyglet-1.1.4-r2.ebuild38
3 files changed, 57 insertions, 13 deletions
diff --git a/dev-python/pyglet/ChangeLog b/dev-python/pyglet/ChangeLog
index 4d39844b9b6b..238a1061f5b9 100644
--- a/dev-python/pyglet/ChangeLog
+++ b/dev-python/pyglet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyglet
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyglet/ChangeLog,v 1.7 2012/04/11 00:03:31 floppym Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyglet/ChangeLog,v 1.8 2013/03/18 12:35:41 jlec Exp $
+
+*pyglet-1.1.4-r2 (18 Mar 2013)
+
+ 18 Mar 2013; Justin Lecher <jlec@gentoo.org> +pyglet-1.1.4-r2.ebuild,
+ metadata.xml:
+ Bump to new python eclasses
11 Apr 2012; Mike Gilbert <floppym@gentoo.org> pyglet-1.1.4-r1.ebuild,
pyglet-1.1.4.ebuild:
diff --git a/dev-python/pyglet/metadata.xml b/dev-python/pyglet/metadata.xml
index afa267cfc01c..c37557b10fb9 100644
--- a/dev-python/pyglet/metadata.xml
+++ b/dev-python/pyglet/metadata.xml
@@ -1,21 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
- <maintainer>
- <email>sci@gentoo.org</email>
- </maintainer>
- <longdescription lang="en">This library provides an object-oriented programming interface
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>sci@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">This library provides an object-oriented programming interface
for developing games and other visually-rich applications with Python.
pyglet has virtually no external dependencies. For most applications
and game requirements, pyglet needs nothing else besides Python,
simplifying distribution and installation. It also handles
multiple windows and fully aware of multi-monitor setups.
pyglet might be seen as an alternative to PyGame.</longdescription>
- <upstream>
- <remote-id type="google-code">pyglet</remote-id>
- </upstream>
+ <upstream>
+ <remote-id type="google-code">pyglet</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/pyglet/pyglet-1.1.4-r2.ebuild b/dev-python/pyglet/pyglet-1.1.4-r2.ebuild
new file mode 100644
index 000000000000..db9cdcbb7aa9
--- /dev/null
+++ b/dev-python/pyglet/pyglet-1.1.4-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyglet/pyglet-1.1.4-r2.ebuild,v 1.1 2013/03/18 12:35:41 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="http://www.pyglet.org/"
+SRC_URI="http://pyglet.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="alsa doc examples gtk +openal"
+
+RDEPEND="
+ virtual/opengl
+ alsa? ( media-libs/alsa-lib[alisp] )
+ gtk? ( x11-libs/gtk+:2 )
+ openal? ( media-libs/openal )"
+DEPEND="${RDEPEND}"
+# ffmpeg? ( media-libs/avbin-bin )
+
+DOCS="NOTICE"
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}