summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-08 00:31:51 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-08 00:31:51 +0000
commit0aa18bcb055de84294d6c2513141932f888d4051 (patch)
tree7814f8e44e277f180ea10fd1516c6cb101d45132 /dev-python/pylint
parentFix dependencies. (diff)
downloadgentoo-2-0aa18bcb055de84294d6c2513141932f888d4051.tar.gz
gentoo-2-0aa18bcb055de84294d6c2513141932f888d4051.tar.bz2
gentoo-2-0aa18bcb055de84294d6c2513141932f888d4051.zip
Fix dependencies.
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/pylint-0.21.0.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/pylint/pylint-0.21.0.ebuild b/dev-python/pylint/pylint-0.21.0.ebuild
index 4c4cba938f2b..667afe596fcf 100644
--- a/dev-python/pylint/pylint-0.21.0.ebuild
+++ b/dev-python/pylint/pylint-0.21.0.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.21.0.ebuild,v 1.1 2010/05/13 18:27:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.21.0.ebuild,v 1.2 2010/06/08 00:31:51 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
PYTHON_USE_WITH="tk"
PYTHON_USE_WITH_OPT="tk"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
-DESCRIPTION="a tool to check if a Python module satisfies a coding standard"
+DESCRIPTION="Python code static checker"
HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -19,10 +20,10 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="doc examples test tk"
-DEPEND=">=dev-python/logilab-common-0.44.0
- >=dev-python/astng-0.20"
+# Versions specified in __pkginfo__.py.
+DEPEND=">=dev-python/logilab-common-0.50.1
+ >=dev-python/astng-0.20.1"
RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
src_prepare() {
distutils_src_prepare