summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-16 19:36:32 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-16 19:36:32 +0000
commit0aa37c36b4c64a665e3fde7ab36657d31949b847 (patch)
tree1005009067f1388818479ede57c010acc98ba9d8 /dev-python/pympler/pympler-0.2.0.ebuild
parentx86 stable wrt bug #397279 (diff)
downloadgentoo-2-0aa37c36b4c64a665e3fde7ab36657d31949b847.tar.gz
gentoo-2-0aa37c36b4c64a665e3fde7ab36657d31949b847.tar.bz2
gentoo-2-0aa37c36b4c64a665e3fde7ab36657d31949b847.zip
Initial commit written by me
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pympler/pympler-0.2.0.ebuild')
-rw-r--r--dev-python/pympler/pympler-0.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pympler/pympler-0.2.0.ebuild b/dev-python/pympler/pympler-0.2.0.ebuild
new file mode 100644
index 000000000000..0813eb40e71e
--- /dev/null
+++ b/dev-python/pympler/pympler-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pympler/pympler-0.2.0.ebuild,v 1.1 2012/02/16 19:36:32 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="memory profiling for Python applications"
+HOMEPAGE="http://code.google.com/p/pympler/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="Apache-2.0"
+IUSE=""
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py test
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" run.py --test --clean
+ }
+ python_execute_function testing
+}